1

Sorry if this is a basic question, but I am new to Ubuntu. I am receiving an error in the top bar saying, "An error occurred, please run Package Manager from the right-click menu or..."

I don't know where the right-click menu is.

  • Where do you see this ? – JonasCz Jun 10 '16 at 17:23
  • Upper right hand corner. I see a sign that looks like a Do not Enter sign with a red circle and a horizontal white bar. – Goldname Jun 10 '16 at 17:25
1

Click the sign that looks like a do not enter sign. This is what's called the right-click menu (for the package manager). If you look in the list of items and messages, there should be a Package Manager link.

I've had this problem before and opening the package manager won't do a lot to fix it but it can help.

If you still get the message after opening the package manager, open a terminal and enter the following commands (these worked for me):

sudo apt-get update

This will (as any command where you use sudo) ask for your password. Enter it and press enter.

Next, enter:

sudo apt-get install -f

This probably will fix the problem. It happens quite a lot when updates get stuck.

  • I don't see anything about the package manager in there. There's just the error message and three options "Show updates", "Show notifications", and "Preferences" – Goldname Jun 10 '16 at 17:38
  • Also, I entered the commands, but the do not enter sign is still there. – Goldname Jun 10 '16 at 17:40
0

The fix is very simple. Open the terminal and run the command sudo apt-get update && sudo apt-get upgrade and then restart your computer.

0

This is happening because you have a corrupt entry in your repository. In order to fix this follow the below instructions.

1)Open the terminal using Ctrl + Alt + T

2) type: sudo apt-get check

This checks for broken repositories.

3) type: sudo apt-get update

This updates the repository file after the above fix.

You may need to restart the computer after doing this for the error to disappear, but it should fix the issue. Any problems, let me know. :)

0

Another good solution is to restart your computer which would usually fix the problem. It gives an opportunity for your repository list to refresh. Try it and say how it goes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.