0

I booted a Ubuntu 16.04 Live USB and installed onto an external HDD. In the partitioning step I had it install grub to the external HDD, not my internal Windows 10 HDD. But when I rebooted the computer, it boots to a grub command line.

In side the UEFI, there is still a Window Boot Manger option, plus 2 Ubuntu boot options. I can still boot to Win10 through the WBM, but the 2 Ubuntu options do nothing.

How can I remove all traces of Grub and the 2 Ubuntu boot options from the Win10 HDD?

3
  • Do as given here : askubuntu.com/questions/781870/… – Severus Tux Jun 10 '16 at 16:10
  • When Windows starts booting, press F8 for the recovery menu. Select "Troubleshooting" and then "Command Prompt". At the command prompt type in bootrec /fixMbr and then bootrec /fixboot. Type exit and reboot. – Delorean Jun 10 '16 at 16:11
  • Already tried that, it does nothing. I just noticed when I delete the Ubuntu boot entries, they reappear after a reboot. When I installed Ubuntu, it had me create a password to disable EFI, but could it have put something in the EFI that needs to be removed? – Brady Dean Jun 10 '16 at 16:15
0

It sounds like GRUB is broken.

Try booting into the live CD again, open a terminal and type sudo update-grub.

This should fix GRUB. Then the Ubuntu boot option in UEFI should go to GRUB which should let you choose between Ubuntu and Windows.

I don't think that removing all traces of GRUB from your hard drive will solve your problems, unless you don't want Ubuntu anymore. WBM does not support Ubuntu but GRUB does support Windows, so it is preferable.

3
  • I was trying to just install Ubuntu to my external HDD, I didn't want anything done to the internal Win10 HDD. – Brady Dean Jun 10 '16 at 16:44
  • How do you know where grub is installed? – wpbdry Jun 10 '16 at 16:51
  • Well Grub was installed as the efi program to ESP/EFI/ubuntu/stuff. Problem was it installed to the wrong ESP. – Brady Dean Jun 11 '16 at 1:59
0

Ok I followed https://askubuntu.com/a/240831/440238 and deleted the Ubuntu boot stuff from Win10's efi partition. The Ubuntu uefi entries are now gone and Windows boots like normal

I've had problems with Ubuntu before where it installs boot files to other HDDs when you specifically tell the installer not to, it really should be fixed.

2
  • Grub only installs to sda in UEFI boot mode. Did you copy boot files to ESP - efi system partition on external drive and create a /EFI/Boot/bootx64.efi boot file? If not external will not boot, it was booting from files in ESP on sda. askubuntu.com/questions/720827/… And: askubuntu.com/questions/63610/… – oldfred Jun 10 '16 at 17:29
  • Right I need to copy those over to make it bootable, at least the bios will find the entry. – Brady Dean Jun 11 '16 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.