0

So I was having connection problems in linux only and then found this: https://chirath02.wordpress.com/2016/05/12/installing-realtek-rtl8723be-driver-for-ubuntu-16-04/

After finding this I have found many answers on this website containing similar info so I thought this would be a good place to ask but anyway...followed those instructions all the way through to the point where it says "If you are not able to see your wifi networks, follow the steps below" but if anything when I got to that point the wifi was even worse than before so i mentioned it to the author and he just said to continue all of the steps so stupidly I did and now I get no wifi connection at all although I can see access points but even when I boot into windows I cant even get a wifi connection there! Although I can see access points in windows aswell...

Basically I just need to undo this and reset if at all possible? If I were to download and re-install the drivers in windows would this fix the issue? If there is a terminal issue that can be solved in Linux I am open to that as well...

I am using ubuntu 16.04

Thanks!

Matt

UPDATE:

I also asked this question over at the Ubuntu Forums and I'm not entirely sure how but I think we have come to a solution. Please see: http://ubuntuforums.org/showthread.php?t=2327345&page=2&p=13503637#post13503637

The last answer was submitted an hour or so ago and the wifi seems to be working fine on my laptop but I get the feeling that as soon as I reboot it is going to give me hassle again...

4
  • This issue has been solved already askubuntu.com/questions/590414/… follow the directions in the answer to solve your driver issue
    – ILOVEKODI
    Jun 10 '16 at 3:51
  • These are the steps that I originally took and now have no access to wifi in windows or linux...read the question please... Jun 10 '16 at 4:55
  • They are not identical..... And did you set the country code to India as it instructed in your link???? Please attempt the procedure verbatim in the link I provided. If read it, they are NOT the same..
    – ILOVEKODI
    Jun 10 '16 at 9:35
  • Followed this through...I can now connect in Windows but still zero connection in Ubuntu Jun 13 '16 at 2:43
0

First I would

cd rtlwifi_new-rock.new_btcoex
sudo make uninstall
as the hanipouspilot ppa already includes that code.

Use this list here to look up your country code and set it with

sudo iw reg set IN
Replace IN with the code you got from the link, you must use capital letters. You should also edit another file with
gksudo gedit /etc/default/crda
The last line will contain REGDOMAIN= add your country code after the = If you are in India it would be REGDOMAIN=IN Save and exit gedit

Reboot

The ant_sel parameter has only been needed in newer HP laptops

3
  • Probably a good idea with the uninstall! Coutry code reset and uninstalled rtlwifi driver as suggested...still zero connection in ubuntu though :/ Jun 13 '16 at 2:44
  • Can you edit your question to include results from the wireless script
    – Jeremy31
    Jun 13 '16 at 9:44
  • Lol Jeremy...I assume you are the same Jeremy31 from over on the Ubuntu forums? Please see: ubuntuforums.org/… I am going to update the original question with this answer. Jun 14 '16 at 4:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.