1

I have an issue in Wireshark for usb monitoring. Apart from the way things worked in the past wireshark(not even seeing ports unless root) now displays the usb ports it can monitor, but it doesn't allow you to actually monitor any of the traffic once you click on one of the ports.

It says permission denied make sure you have the correct permissions.

When the program was being installed it suggested I not run the program as root and instead add the wireshark group to my user account.

I did that, but still not working. I have look at several questions answered that are closely related, but not the same.

I think something in 16.04 changed versus previous version, or I am missing something.

So how can I get this working?

Just to add I tried - Wireshark - allow non-root user to sniff USB traffic

It did not help.

0

After reading through the wireshark documentation I discovered that usbmon module needs to be activated for everything to work properly.

If you are running into this problem which you likely are if you are using 16.04 since it appears this module isn't active by default in the kernel.

modprobe usbmon

After that you should be able to use any of the devices listed. At least this worked for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.