2

I am posting this as a solution to a problem that I could not find anywhere on Google.

Redshift will not launch on startup as it has issues gathering longitude and latitude from geoclue. The issue appears to be with geoclue failing to get the users location.

Trying the following in terminal DOES NOT work for me:

redshift-gtk -l 55.7:12.6

I get an error stating too many arguments.

  • Great job answering your own question! However, for future reference, you can use the "answer your own question" check box and write your answer in an answer post instead of in your question post. You can even accept your own answers! This is a great way to share your knowledge with the community. – user323419 Jun 9 '16 at 16:07
4

Here's what I did to get it to work:

1) Under applications, go to Startup Applications. If an entry for Redshift already exists then click on it and then click on edit. Otherwise, click add. Set name to Redshift and set the comment to whatever you want. For the command, enter:

gtk-redshift -l manual

Click save.

2) In your home folder press ctrl+h and that should list all of the hidden folders(folders beginning with a '.'). Go into your .config folder and create a new file and call it redshift.conf. Paste the following:

; Global settings
[redshift]
temp-day=6500K
temp-night=5000
transition=1
;gamma=0.8:0.7:0.8
gamma=1.000:1.000:1.000
location-provider=geoclue
;location-provider=manual
adjustment-method=vidmode
;brightness=1.0:0.5

; The location provider and adjustment method settings
; are in their own sections.
; This is an example lat long for Portland, OR
[manual]
lat=YOURLAT
lon=YOURLON

; In this example screen 1 is adjusted by vidmode. Note
; that the numbering starts from 0, so this is actually
; the second screen.
;[vidmode]
;screen=1

Go here to get your latitude and longitude and replace 'YOURLAT' and 'YOURLON' with the respective values. Save and close the file. Restart computer and Redshift should have started(indicated by the lightbulb icon the the menu bar).

So, hopefully this helps someone. If this is against the rules or anything for whatever reason I apologize. Hopefully this helps someone out there.

  • good answer, but your config file looks a bit funny. the night temp is set very high, so someone might think this does not work. jonls.dk/redshift/#configuration-file – Tom Carchrae Jun 19 '16 at 15:51
  • I found the config file from another site and I didn't play with it much. It was more of a case of 'now it's working, let's play with it'. – tozer83 Jun 22 '16 at 17:29
0

while the above answer put me on the right path, there are a few things that can be improved. if you add the config location-provider=manual then you don't need any extra command line arguments and just running redshift or redshift-gtk will load your config file lat/long.

i don't know why geoclue is busted on ubuntu, but since this is for my desktop computer, the location doesn't change much

here is my modified config. see the docs here http://jonls.dk/redshift/#configuration-file

; Global settings
[redshift]
temp-day=5700
temp-night=3500

transition=0

; Set the screen gamma (for all colors, or each color channel
; individually)
gamma=0.8

;location-provider=geoclue
location-provider=manual

; Set the adjustment-method: 'randr', 'vidmode'
; type 'redshift -m list' to see all possible values.
; 'randr' is the preferred method, 'vidmode' is an older API.
; but works in some cases when 'randr' does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

;brightness=1.0:0.5

; The location provider and adjustment method settings
; are in their own sections.
; This is an example lat long for Portland, OR
[manual]

lat=49.000  ;  YOUR LAT GOES HERE
lon=-123.000 ; YOUR LONG GOES HERE

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.