I tried to install RStudio after installing R in Ubuntu. When I clicked to install via Ubuntu software, clicking the install button does nothing. But sometimes when I click it, it starts loading and after a while it says rstudio installed. But it's not really installed.

So I installed it via terminal using:

$ sudo dpkg -i rstudio-0.99.902-i386.deb 
Selecting previously unselected package rstudio.
(Reading database ... 175645 files and directories currently installed.)
Preparing to unpack rstudio-0.99.902-i386.deb ...
Unpacking rstudio (0.99.902) ...
dpkg: dependency problems prevent configuration of rstudio:
 rstudio depends on libjpeg62; however:
  Package libjpeg62 is not installed.
 rstudio depends on libgstreamer0.10-0; however:
  Package libgstreamer0.10-0 is not installed.
 rstudio depends on libgstreamer-plugins-base0.10-0; however:
  Package libgstreamer-plugins-base0.10-0 is not installed.

dpkg: error processing package rstudio (--install):
 dependency problems - leaving unconfigured
Processing triggers for shared-mime-info (1.5-2) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:

What are the steps to rectify this error?

  • The inability to install a .deb package through the 16.04 Software Center is a well known bug. My answer fixes your dpkg issue.
    – user323419
    Jun 9, 2016 at 15:38
  • Answer provided here: askubuntu.com/a/882053/313415 helped me.
    – leevanoetz
    Apr 4, 2017 at 9:51

5 Answers 5


Installing from a .deb file through dpkg does not resolve dependency issues the same way installation through apt will. After running the sudo dpkg -i yourpackage.deb, you should run sudo apt-get install -f to fix and complete the installation if any errors were encountered by dpkg.


Your best bet is to use gdebi to do RStudio installations. It automatically resolves dependencies (unlike dpkg).

sudo apt-get install gdebi-core
sudo gdebi rstudio-0.99.902-i386.deb

In fact, that's what RStudio themselves recommends for rstudio-server installation.


For me it worked like this:

Add the following entry in /etc/apt/sources.list file

deb https://cran.cnr.berkeley.edu/bin/linux/ubuntu xenial/

All the mirrors are listed here:

You can find out your corresponding Ubuntu release by doing this on command line

lsb_release -a

After that

sudo apt-get update
sudo apt-get install r-base

I had the same problem but i downloaded the dependency from the link below


followed by

sudo apt-get update

After downloading the zipped file use

sudo dpkg -i libjpeg62-turbo_1.5.1-2_amd64.deb

to install the deb file to solve the dependency issues.

After that try and install R studio with

sudo dpkg -i rstudio-xenial-1.1.379-amd64.deb

and this should solve the problem. This should solve the problem and even if your software installer on ubuntu is not working.

Please and in case you see any other dependencies that you need to download just download it and use the above procedure and it should work. hope this works for you.


For me, it worked when I've installed the follow dependencies:

libgstreamer-plugins-base0.10-0_0.10.36-2ubuntu0.1_amd64.deb libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb libjpeg62-turbo_1.5.2-2+b1_amd64.deb

All from https://packages.ubuntu.com/

Not the answer you're looking for? Browse other questions tagged .