1

I'm trying to install libboost-thread1.54.0 (I need this specific version) using this command: sudo apt-get install libboost-thread1.54.0 but it throws me this error:

Reading package lists... Done 
Building dependency tree
Reading state information... Done 
E: Unable to locate package libboost-thread1.54.0 
E: Couldn't find any package by glob 'libboost-thread1.54.0'
E: Couldn't find any package by regex 'libboost-thread1.54.0'

However, I find the package here, it seems that Ubuntu doesn't recognize it.

In the same page, in the right panel there are download links but I don't know really which one it's for me. Can't find any direct answer in google either. I really need that package installed, I know there are newer versions but I need that one.

Working on Ubuntu 16.04 LTS.

PS: I have this error, thats why I need the libboost-thread1.54.0

  • Are you sure you have the correct repo(s) enabled? Perhaps copy in your repo list? – Zeiss Ikon Jun 9 '16 at 12:50
  • Did you run sudo apt-get update ? – thangdc94 Jun 9 '16 at 12:55
  • I ran sudo apt-get update, same error. I also try with libboost-thread1.54-dev, it throws me this error: Package libboost-thread1.54-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'libboost-thread1.54-dev' has no installation candidate – Cris Jun 9 '16 at 13:16
  • oh sorry, I very lazily did not read that you're using 16.04. You can go here for 64-bit or here for 32-bit and download the .deb package from a local mirror, then go to the directory with the file (cd Downloads for example) and do sudo dpkg -i name-of-package.deb (replace with actual name) – Zanna Jun 9 '16 at 14:10
  • Thanks! I installed it and it worked fine. Thanks a lot! – Cris Jun 10 '16 at 13:36
2

Version 1.58 of libboost-thread exists in Ubuntu 16.04. Install it by typing the following in a Terminal Window:

sudo apt install libboost-thread1.58.0
  • Thanks, but I need the 1.54 version for a program that work with it. It doesn't work or recognize any other versions. – Cris Jun 9 '16 at 13:18
  • It seems that version 1.54 is available for Ubuntu 16.04 as part of a repository. You could try to compile it from source. – PenguinCSC Jun 9 '16 at 13:44
0

Have you tried Y PPA? Link to Y PPA info

It sorted my last "package not found" issue, allowing me to search all PPA's for the package I wanted.

to install;

sudo add-apt-repository ppa:webupd8team/y-ppa-manager

sudo apt-get update

sudo apt-get install y-ppa-manager

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.