2

I'm trying to compile a LaTeX document with the revtex package, but I get a compiling error stating "File ŕevtex4.sty'not found". Here's what I've tried so far with no success, based on my own digging and common internet solutions:

  • Installing texlive-publishers; apt says it's already installed (and reinstalling is no help);
  • Replacing revtex4 with revtex4-1 or revtex; those other *.sty files are also not found;
  • Running sudo texhash;
  • Changing engines (I've tried PdsLaTeX, LatexMk, XeLaTeX and LuaLaTeX);
  • Using different editors.

BTW, texlive-extras and texlive-full are also installed. Running apt show texlive-publishers I see the latter package has no breakage or conflict problem with the others.


Here's a minimal working example:

\documentclass{article}
\usepackage{revtex4-1}
\begin{document}
\end{document}

In my machine, I get the log below.

enter image description here

  • 2
    Can you post a snippet of the top your file? It should load revtex4.cls and not .sty --- unless it is a very, very old document using a legacy LaTeX. – Rmano Jun 9 '16 at 7:20
  • @Rmano, sure, I've added an MWE as well as my LaTeXila log. I've just started writing this article, so I guess I'm not depending on anything legacy. Let me know if I can provide any other info. – Waldir Leoncio Jun 9 '16 at 7:27
2

It works for me (Ubuntu 16.04, TeXLive 2015) if I change the snippet into:

\documentclass{revtex4-1}
\begin{document}
\end{document}

It outputs a warning:

Class revtex4 Warning: No Society specified, using generic APS style.

So probably it needs some options to tailor it for the journal. You can see the documentation with

texdoc revtex 

(if texdoc doesn't work, search for a file named aipguide4-1.pdfin your system)

second page of the docs

So for example for Journal of Applied Physics you should use:

\documentclass[aip,jap]{revtex4-1}
  • That works for me too! Dropping the article class and using revtex feels weird, but I hope there are no bigger consequences than what I've faced so far (title, author, etc. had to be placed after \begin{document}, and biblatex stopped working). – Waldir Leoncio Jun 9 '16 at 8:20
  • 1
    Probably the class wants to use bibtex - it seems it has built-in bibliography formats. Happy to help! – Rmano Jun 9 '16 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.