5

How I can disable in Google client=ubuntu (in DDG t=canonical) in Firefox 47?
See screenshot:

enter image description here

UPD: That's all what i find about subj,

>strings /usr/lib/firefox/libxul.so | grep "client=" -n

208606: GetCacheSession for client=%s, policy=%d

but more interesting about Canonical partners. Seems, installing FF from official repo can negatively affect your right to privacy.

5
  • See if you can uninstall xul-ext-ubufox.
    – DK Bose
    Jun 9, 2016 at 6:55
  • @DKBose i purge this pkg, but client name present
    – Andrew
    Jun 9, 2016 at 10:29
  • Also, duckduckgo include canonical string [screenshot] (dl.dropboxusercontent.com/1/view/cecro1yft0xean8/Apps/Shutter/…)
    – Andrew
    Jun 9, 2016 at 10:36
  • Hmmm... if that's really a problem for you, install Firefox 47 direct from Mozilla (mozilla.org/en-US/firefox/channel). That's what I'm using (for other reasons). It doesn't show "client name" in the search bar for Google. I don't use DDG.
    – DK Bose
    Jun 9, 2016 at 10:40
  • Bad idea install not from repo.
    – Andrew
    Jun 9, 2016 at 10:50

1 Answer 1

-1

I think what you are looking for is a "do not track" function. Firefox does have something that you could try and use.

See link It's disabled by default.

The Do Not Track feature is turned off by default. To turn it on:

Click the menu button and choose Options.
Select the Privacy panel.
Click manage your Do Not Track settings.
Check Use Do Not Track.
Close the about:preferences page. 
Any changes you've made will automatically be saved.

see: The official mozilla site

2
  • 1
    DNT enable, but client name present screenshot
    – Andrew
    Jun 9, 2016 at 10:31
  • 1
    Don't forget "individual websites are not required to respect it" - If you really want it to be completly without notice who you are maybe try using some kind of sandbox.
    – Ziazis
    Jun 9, 2016 at 11:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.