I have a Lenovo Yoga 13 and I was running 14.04 on it and I've since upgraded to 16.04. I applied the fix descibed here (Lenovo Yoga 13 Realtek wireless driver) with 14.04 and it worked but no longer seems to with 16.04. I know that the way Realtek drivers work was reorganized in Linux kernel 4.4 (https://www.phoronix.com/scan.php?page=news_item&px=Linux-4.4-Networking) however I don't know enough about what was changed to know if that was the problem. Has anyone else experienced this issue or know how to fix it?

  • I believe the driver r8723au exists in Ubuntu 16.04 by default. Check: modinfo r8723au – chili555 Jun 8 '16 at 20:33
  • @chili555 the driver does indeed exist but for some reason does not allow me to access the internet. I know the hardware is good and a wireless USB dongle allows me to connect to my wifi. – bamb00zled Jun 8 '16 at 20:58

Well I hope no one else has this problem but I ended up fixing it by updating my kernel as described here: How to update kernel to the latest mainline version without any Distro-upgrade?.


I had the same issue and followed the answer given by @bamb00zled.

Go here: http://kernel.ubuntu.com/~kernel-ppa/mainline/ Download 3 (maybe 4) debs to a folder somewhere:





if available

Install the debs with whatever package manager front-end you use (is gdebi still around?), or use these commands:

cd /path/to/folder/where/you/put/the/debs

sudo dpkg -i *.deb


As suggested here, type in the following command into your terminal:

sudo rmmod rtl8xxxu && sudo modprobe rtl8xxxu

This helped me.

You need to run it after every reboot.


I tried all the above steps with no success (well I managed to update the kernel, but that didn't solve the issue for me) - what did fix the issue for me was entering the bios (button at the front, left of the power button with the bent arrow on it) and not only setting the boot option to "Legacy" mode, but also "prefered option" (try legacy first) in the boot mode.

Also there was a complete cold start in between (so no rebooting but really powering off)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.