0

I have an Acer Aspire E15 which came with windows 10 installed. I followed the instructions here and the follow-on links in the article to install Ubuntu alongside Windows-10.
I choose the partition sizes according to the requirements of the app (X-Plane 10) that I wish to install.
However after the first install (15.10) I was only able to boot into Ubuntu once, and that after following grub repair advice I found in these forums.
Subsequent attempts to boot into Ubuntu have all failed. I enabled F12 boot menu in the BIOS, but it only shows the Windows boot manager.
I then redid the installation to 14.04 but Same problem.

I ran the Boot Repair app and it gave the following boot info output file here

I also ran:

sudo efibootmgr -v 

and the output is below:


BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2001,0002,2002,2003
Boot0000* ubuntu    HD(1,800,32000,2d2d5e4a-4950-42e1-b7f4-3f63e2965a2d)File(\EFI\ubuntu\shimx64.efi)
Boot0001* USB HDD: SanDisk Cruzer Glide ACPI(a0341d0,0)PCI(14,0)USB(3,0)HD(1,20,1d3d7e0,00000000)RC
Boot0002* Windows Boot Manager  HD(1,800,32000,2d2d5e4a-4950-42e1-b7f4-3f63e2965a2d)File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0003* Unknown Device:   HD(1,800,32000,2d2d5e4a-4950-42e1-b7f4-3f63e2965a2d)File(\EFI\ubuntu\shimx64.efi)RC
Boot0004* Unknown Device:   HD(1,800,32000,2d2d5e4a-4950-42e1-b7f4-3f63e2965a2d)File(\EFI\ubuntu\shimx64.efi)RC
Boot0005* Unknown Device:   HD(1,800,32000,2d2d5e4a-4950-42e1-b7f4-3f63e2965a2d)File(\EFI\ubuntu\shimx64.efi)RC
Boot0006* Unknown Device:   HD(1,800,32000,2d2d5e4a-4950-42e1-b7f4-3f63e2965a2d)File(\EFI\ubuntu\shimx64.efi)RC
Boot2001* EFI USB Device    RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC


  [1]: http://www.pcsteps.com/3057-full-windows-backup-image/ "here"
  [2]: http://www.pcsteps.com/3305-prepare-windows-dual-boot-installation/ "here"
  [3]: http://www.pcsteps.com/961-install-ubuntu-linux-windows/ "here"
  [4]: http://paste.ubuntu.com/17117458/ "here"  

I have hunted high and low in the forums but nothing seems to help. Any assistance will be appreciated.

4
  • Sounds like you went to hell and back
    – Zuko
    Jun 8, 2016 at 19:43
  • install Ubuntu alongside windows and the boot into Ubuntu and update your grub sudo update-grub and reboot. let me know how it goes
    – Zuko
    Jun 8, 2016 at 19:43
  • Acer is the only one that has the unique requirement of setting an UEFI password and "trust" on grub/shim .efi boot files. Some Acer threads also mention downgrading UEFI, but newer threads say newest UEFI from Acer works. So make sure you have newest from Acer. Steps 36-40: askubuntu.com/questions/627416/… and: Acer Cloudbook shows screen for selecting trust bernaerts.dyndns.org/linux/74-ubuntu/…
    – oldfred
    Jun 8, 2016 at 19:52
  • See my comment below about the password, it might well be the key, I will try on the weekend and report back. I do recall flashing the BIOS a while back. I can't remember the exact details but it was indeed necessary.
    – Raffles
    Jun 9, 2016 at 19:41

2 Answers 2

1

It sounds like Windows or your computer's BIOS has kicked GRUB off. Newer PC's that come with Windows 8+ generally have an option (secure boot, enabled by default) that will check the boot loader before it can start up your computer, and if it doesn't have a certificate for that boot loader, it will not be allowed to start up the computer. This is handy because it makes it much harder for rootkits to corrupt your startup process, but it can also make it harder to dual boot with other OS's, in this case, Linux. (More info here.) I'm guessing this is why you're having trouble. I would try going into your UEFI configuration (the more modern BIOS), disable secure boot, and see if it then allows Linux to boot, although you might have to reinstall GRUB to test this, the process for which I'll explain later on. If it works, you can either leave secure boot off or try to figure out how to add a secturity certificate for GRUB so you can enjoy the security of secure boot plus the versatility of a dual-boot computer. (I've never done this, so I'm not sure how hard it is.)

For fixing/reinstalling GRUB, I generally use GRUB Customizer, which allows you to tweak GRUB with a GUI rather than from the terminal. Boot from a USB drive or live CD and you should be able to make changes to GRUB on your hard drive. To install it, run these commands in the terminal:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer sudo apt-get update sudo apt-get install grub-customizer

After installation, it can be run from the terminal (sudo grub-customizer) or from the Unity dash. Make sure it's set to work on your hard drive and not on your USB drive; use GParted or lsblk to check your drive letters if you're not sure. As it starts up, it should detect all your bootable operating systems: Ubuntu, Advanced options for Ubuntu, Windows, and possibly also memtest86+. If there's something missing, I'm afraid I can't help you much. If, however, everything shows up, you can change the names, order, general settings, and appearance settings to suit your preferences, then select File > Save and File > Install to MBR (make sure it's targeting your hard drive). This should ensure that this GRUB configuration is installed as the first boot loader on your hard drive. If GRUB is already installed to the MBR, I think that save should be all that you need to do to apply changes, but I'm not entirely sure.

With that, it should be fine unless Windows attempts to reinstall its own boot loader before GRUB, but on my dual-booting desktop, I haven't had that problem.

3
  • Hi, disabling secure boot does not allow Linux to boot. It removes some of the boot options.
    – Raffles
    Jun 8, 2016 at 21:30
  • Have you also reinstalled GRUB to the MBR? This will probably be necessary in addition to disabling secure boot. Jun 8, 2016 at 21:41
  • I have carried out all the Grub repairs with Boot Repair, and in the terminal. I just read something above which reminds me of what I did the one and only time that I was able to boot into Ubuntu....set a UEFI supervisor password...goto this link and scroll right down to the bottom in the comments section there is a comment by "Ying Xiong" to which I(Ralph W) replied . The supervisor password might be the key. I will try it and report back during the weekend.
    – Raffles
    Jun 9, 2016 at 19:34
1

The procedure outlined here worked. I only needed to carry out step 3 onwards. It has to do with setting the Ubuntu image as trusted in UEFI, something which you are unlikely to stumble upon by chance.

The essential point is that by default Secure boot is Enabled and your laptop refuses to boot any unknown image.

You need to add the newly installed Ubuntu boot image to the UEFI database.

This is done thru the Bios(UEFI) with some simple steps. It is mandatory to set a supervisor password, but beware... make sure you write it down in a safe place. You can remove it later.

Once you set the password, the options below it become available.
Enter the "Select an UEFI file for trusted as executing" option.
Select EMMC >> EFI >> Ubuntu and select the file shimx64.efi. You will be prompted to give it a name of your choice (which will appear in the F12 boot options).
Type the name press Enter and then "Yes" should be highlighted.
Press enter again. Restart the computer without any boot disk and tap F12 during the boot process.
You should now get the boot option menu with the name you chose.

Final edit: you can change the boot order in UEFI now so that it boots directly to the Grub screen.

1
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Videonauth
    Jun 10, 2016 at 17:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .