5

I've recently switched to using Ubuntu 16.04 on my XPS-15-9550 and so far everything is fine except I'm unable to connect my Bose Soundlink II headphones.

I've read through various posts detailing problems with Ubuntu and Bluetooth headsets, and have tried suggested fixes but so far haven't got anything to work. I have read that it is possible so here is where I'm at currently.

I've removed Blueman as this didn't work and my bluetooth should be back to the default state.

I try using the bluetooth manager gui and it fails to connect.

I then try in terminal first of all using bluetoothctl

  • scan on
  • connect [Device Mac Address] - This returns Failed to connect: org.bluez.Error.Failed

  • pair [Device Mac Address] - This returns:

Attempting to pair with [Device Mac Address] [CHG] Device [Device Mac Address] Connected: yes Failed to pair: org.bluez.Error.AuthenticationFailed [CHG] Device [Device Mac Address] Connected: no

Now I have read this has something to do with Pulseaudio and in particular a specific module needing to be started, this being "module-bluetooth-discover"

I've tried:

pactl load-module module-bluetooth-discover

And regardless of whether I run it with or without root privileges I get the following:

Failure: Module initialisation failed

I've tried so much to get this working can anyone suggest how I can go about getting this to work?

Thanks

0

So what worked for me is this -

  1. Disconnect Bose headphones from Blueman-applet
  2. run commands: sudo apt-get install pulseaudio-module-bluetooth pactl load-module module-bluetooth-discover
  3. turn off Bose
  4. turn on Bose and put Bose into paring mode
  5. on Blueman applet right click and select setup new device
  6. Select Bose headphones as device, then pair, then connect to hands free
  7. finish pairing device and set it as trusted device
  8. right click bose-applet > select recent device > select bose headphones
  9. you should be connected! head to sound settings and change bose audio profile to a2dp sink instead of handset headunit (hsp...)

note: may be easier to select headphones in step 6 but I have not tried so

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.