Enigmail! It's great for remaining secure.

When it works, anyways. I seem to have a bit of an issue with Enigmail in which I can click on an encrypted email, but the email simply shows a blank page and no error message is thrown. I can't tell what is broken, and no FAQs are really being helpful, either. I've tried a reinstall of gpg and gpg2, but that doesn't help either.

Ubuntu v16.04, Thunderbird v38.8.0, Enigmail v1.9.3

  • This sounds like some issue with gpg-agent. Is GnuPG working fine if used from the command line?
    – Jens Erat
    Jun 11, 2016 at 18:56
  • That's what I thought, but I ran Kleopatra and it said it connected to gpg-agent just fine. I just did a clean install of Kubuntu, anyways, and now it works. Jun 11, 2016 at 18:58
  • Issues with GnuPG and especiallly gpg-agent are sometimes really difficult to track down, and involve heavy usage of the command line and manually starting gpg-agent with extended logging. Glad to hear you were able to resolve the issue, anyway.
    – Jens Erat
    Jun 11, 2016 at 19:08

2 Answers 2


How I solved this:

Essentially, the only sane way I could find of fixing this was to completely reinstall the OS. I was able to do an export of my previous enigmail settings (including the key) and subsequently import it to a different client. I moved from Ubuntu 16.04 to Kubuntu 16.04, so there should be little difference behind-the-scenes, there.

Either way, that's it. If you're having a similar issue and don't want a reinstall, try making a new question. Sorry for not providing a cleaner solution.


An old question, but Enigmail still fails silently on occasion. Three possibilities:

  1. A non-obvious problem with gpg. Try running gpg -k on the command line. If it hangs, you may have a poisoned key in your pubring.gpg. See here for an explanation and a one-liner to detect the poisoned key (requires gpg 2 or later). You may also find it quicker simpler to replace pubring.gpg from a backup. Sometimes there may be one in the same directory.
  2. Some problem with gpg-agent and the pinentry method. See Resolving issues with GnuPG 2.x and gpg-agent on the Enigmail site.
  3. Corrupt Enigmail storage. Close Thunderbird, and find which profile directory you are using. Within that there should be a file enigmail.sqlite. Move that to a backup location. Restart Thunderbird and try again.

For example, I had a situation when the Key Management dialogue did not appear, or on the second attempt it appeared and rapidly closed. The answer turned out to be case 1 above, with a 22M key from Torproject.org.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.