1

Solved! If someone needs tips for clean install of ubuntu touch, you can contact me.

Edit: Only thing what is solved is how to reinstall os. Still have issues with carrier in Finland.

I bought Meizu Pro 5 Ubuntu Edition about month ago from jd.com. Device was shipped with OTA-10.2 and everything was working fine. Some little problems first when i was calling and my number wasn't showing. I got that fixed by disabling "private number" from my carrier services.

Now the problem is that when i upgraded to OTA-11, i'm losing 2G/3G connecting randomly and quite often. Signal indicator shows most of the time at least half signal both 2G and 3G, but i cannot receive calls. And when i realize that i cannot receive calls and try to call someone, signal just drops down and i cannot make a call. Sometimes this gets fixed for sometime when i just reboot, but not every time.

I have been checking 2G/3G data connections and realized that also data connections does that. - When i choose data connection "only 2G" or "2G/3G" and start using it, signal drops down or data transfer speeds are incredible slow. Looks like 4G is working fine.

At the same time when I upgraded to OTA-11, i installed Unity tweak tool from Openstore to try out what i can do with that. So UT-tool can also be the cause of this problem. I have tried phones own "recover" multiple times, but i don't think that will wipe all the data.

I guess the best solution is that somehow i have to wipe all the data, including system data from my device and reinstall the OS. I think i wanna try to get OTA-10.2 back and see if there is this kind of issues and then upgrade to OTA-11 and see how it works.

Does anyone know "easy" way to do this? I'm quite new with Linux systems... Or some other solution?

Some other information: My carrier Sonera Finland. Done some Googling and i'm quite sure my device is "international version", unrooted, unlocked

Thanks already

5
  • Yeah I contact you… if you solved your problem please post an answer how you did it or accept an existing answer that worked. – LiveWireBT Jul 6 '16 at 3:55
  • For reinstall OS there is couple of links what i had to use: Install "TWRP 3.0": forum.xda-developers.com/meizu-mx/general/… . Use this introduction to install OS: developer.ubuntu.com/en/phone/devices/… . I tried to reinstall without "TWRP" but got stucked to bootloader. You can find image channels from here: developer.ubuntu.com/en/phone/devices/image-channels . – SuperIke Jul 28 '16 at 13:02
  • Wiping data and reinstalling OS wasn't very easy and i had to learn much about adb, flashing and other stuff like that. If you need, i can try to do simplier introduction for reinstall. – SuperIke Jul 28 '16 at 13:02
  • Okay the only thing that worked for you was flashing Ubuntu anew to the device and you ran into the issue that the default Recovery doesn't support ADB. wiki.ubuntu.com/Touch/Devices has links to official ADB recovery images but if TWRP worked for you thats fine too. User Sturmflut wrote about using ubuntu-device-flash with a different recovery image. That would make a good answer to post below and we have another solved question or at least other users can take it up from there. :) – LiveWireBT Jul 28 '16 at 13:42
  • Yeah, i have to check out that Sturmflut's stuff – SuperIke Jul 28 '16 at 20:51
0

I have been experiencing the same issues as you with my mobile data on my bq Aquaris E5 (which is also running OTA-11). I have raised this before here, under the following question Ubuntu Touch - Mobile Data becoming increasingly unusable I have not decided to flush the phone as yet, but can understand your thought process behind doing that. For me, my wife is on the same network and if I have no signal, she always has one on her Samsung S5. I get better coverage on 2G. I have also found that if I turn the phone to flight mode and then back again, the mobile data works for a bit and then seems to time out. If I go on to a webpage and then refresh it, the Internet seems to come on, like it is sleeping without any activity. However, if this is the case certain things do not seem to wake it up like new Telegram messages and such like.

Not possibly the answer you were looking for, but at least you know that you are not the only one with this issue. I will be raising this in Launchpad shortly.

2
  • Actually, only thing what was solved is "how i can reinstall os". I still have issues with OTA-10.2, OTA-11 and latest OTA-12. Interesting thing is that i was working 4 days in Sweden and there was no problems with 2G/3G/4G. I contacted my carrier in Finland today and they said their networks do not have any limits about devices. I found some forum post about "enabling more lte bands" for MX5 Android version and i guess there is something in firmware what is "causing" the problems... – SuperIke Jul 28 '16 at 12:40
  • Since the lated Touch release OTA-12, I have noticed that my movile ddata issue is getting better on my E5. It seems to be cutting out less and now I have a signal in places I didn't before. I think the latest releasr is going in the right direction. I only hope that furthet releasea can build upon this success when it cones to mobile data. – Phil UK Jul 28 '16 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.