Ubuntu tries to be helpful remembering touchpad state between reboots... I hate it!

I mean if i don't enable touchpad before rebooting, after boot i will have physical switch by default enabling touchpad, but software switch will remember the disabled state - so now when i turn the physical switch it toggles both physical and software state (so now i have physical disabled and software enabled).

So basically i can't use mouse if i don't plug in external one and then manually tick checkbox in settings dialog.

In some previous ubuntu version it was possible to decouple hardware touchpad switch with system-stored state, so i could have touchpad alway enabled in system, but disable it physically. But i can't find anything in 16.04.

Also all solutions for this problem i found are from 2014 or older...

Thanks in advance for help

EDIT: xinput output

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ RAPOO RAPOO 2.4G Wireless Device          id=16   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
↳ Power Button                              id=6    [slave  keyboard (3)]
↳ Video Bus                                 id=7    [slave  keyboard (3)]
↳ Video Bus                                 id=8    [slave  keyboard (3)]
↳ Power Button                              id=9    [slave  keyboard (3)]
↳ Sleep Button                              id=10   [slave  keyboard (3)]
↳ BisonCam, NB Pro                          id=11   [slave  keyboard (3)]
↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
↳ MSI WMI hotkeys                           id=14   [slave  keyboard (3)]
↳ RAPOO RAPOO 2.4G Wireless Device          id=15   [slave  keyboard (3)]

EDIT: xinput list-props 13 output

Device 'ETPS/2 Elantech Touchpad':
Device Enabled (139):   0
Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
Device Accel Profile (265): 1
Device Accel Constant Deceleration (266):   2.500000
Device Accel Adaptive Deceleration (267):   1.000000
Device Accel Velocity Scaling (268):    12.500000
Synaptics Edges (269):  94, 2262, 66, 1174
Synaptics Finger (270): 1, 1, 0
Synaptics Tap Time (271):   180
Synaptics Tap Move (272):   117
Synaptics Tap Durations (273):  180, 100, 100
Synaptics ClickPad (274):   0
Synaptics Middle Button Timeout (275):  75
Synaptics Two-Finger Pressure (276):    282
Synaptics Two-Finger Width (277):   7
Synaptics Scrolling Distance (278): 53, 53
Synaptics Edge Scrolling (279): 0, 0, 0
Synaptics Two-Finger Scrolling (280):   1, 1
Synaptics Move Speed (281): 1.000000, 1.750000, 0.075131, 0.000000
Synaptics Off (282):    2
Synaptics Locked Drags (283):   0
Synaptics Locked Drags Timeout (284):   5000
Synaptics Tap Action (285): 2, 3, 0, 0, 1, 3, 0
Synaptics Click Action (286):   1, 1, 0
Synaptics Circular Scrolling (287): 0
Synaptics Circular Scrolling Distance (288):    0.100000
Synaptics Circular Scrolling Trigger (289): 0
Synaptics Circular Pad (290):   0
Synaptics Palm Detection (291): 0
Synaptics Palm Dimensions (292):    10, 200
Synaptics Coasting Speed (293): 20.000000, 50.000000
Synaptics Pressure Motion (294):    30, 160
Synaptics Pressure Motion Factor (295): 1.000000, 1.000000
Synaptics Resolution Detect (296):  1
Synaptics Grab Event Device (297):  0
Synaptics Gestures (298):   1
Synaptics Capabilities (299):   1, 0, 1, 1, 1, 1, 1
Synaptics Pad Resolution (300): 31, 31
Synaptics Area (301):   0, 0, 0, 0
Synaptics Noise Cancellation (302): 13, 13
Device Product ID (260):    2, 14
Device Node (261):  "/dev/input/event7"
  • You can run a touchpad enabling command at startup. But it depends on what user space driver is used. Can you post output of xinput command? – Pilot6 Jun 8 '16 at 9:47
  • And now please post xinput list-props 13. It is better to edit your question and post the information there. – Pilot6 Jun 8 '16 at 9:50
up vote 1 down vote accepted

This looks like a xorg-synaptics glitch.

A way to solve it is to install libinput. It will replace synaptics

Run

sudo apt-get install xserver-xorg-input-libinput

and reboot.

You can see this Q&A for some more details.

Note: You will not be able to use GUI touchpad settings, because Ubuntu with unity DE does not fully support libinput yet. But you can use CLI for touchpad settings.

Tapping is disabled by default in libinput. You can enable it.

  • It won't work from rc, becuase it is too early. – Pilot6 Jun 8 '16 at 9:58
  • But does the command work? – Pilot6 Jun 8 '16 at 9:59
  • Do you mean that the command does not work when you run it from terminal? Does "list-props" still show "Device Enabled (139): 0"? – Pilot6 Jun 8 '16 at 10:02
  • Does the command work in terminal? Does it enable the touchpad? – Pilot6 Jun 8 '16 at 10:11
  • It is not supposed to do it on boot. Did you add it to Startup Applications? – Pilot6 Jun 8 '16 at 10:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.