6

In Ubuntu 16.04 LTS open in terminal command in right click menu always start the terminal with /home/user as working directory. Is there anyway to make it's functionality same as nautilus-open-terminal where terminal opens with current working directory where I have right clicked? I am using zsh as my default shell.

7
  • which file manager are you using?
    – rancho
    Jun 7, 2016 at 22:02
  • Use your file manager and navigate to the desired location. Right-click on the white space in the files window and choose Open Terminal here.
    – ipse lute
    Jun 7, 2016 at 22:34
  • @rancho I use nautilus. Jun 9, 2016 at 11:36
  • @ipselute I know what you are saying but I want my terminal's working directory to the place where I right clicked not /home/user . Jun 9, 2016 at 11:37
  • @vikrant: Open a Terminal window and type: cd /path_to_desired_directory. cd is the command for changing the directory. Replace /path_to_desired_directory with your desired location (like /folder/subfolder/subfolder/...). Open Terminal here works for me in Thunar.
    – ipse lute
    Jun 9, 2016 at 11:51

3 Answers 3

7

Okay, I guess I've found a fix for this. So, launch terminal go to Edit -> Profile Preferences -> Command and uncheck the option saying Run a custom command instead of my shell.

4
  • 1
    My config is already uncheck it but I check and uncheck and all is working good, thanks
    – Jared Chu
    Oct 26, 2016 at 13:00
  • 1
    But it's not working with Desktop :(
    – Jared Chu
    Oct 26, 2016 at 13:01
  • 2
    Yes, that's annoying actually. But, if you're browsing the Desktop as a folder inside nautilus, it works fine.
    – Nikhil H
    Oct 29, 2016 at 19:06
  • But I want to use zsh with this checked.
    – xgdgsc
    Aug 19, 2019 at 2:35
0

Type in a Terminal window: sudo su, hit Enter and then type nautilus. In the Nautilus window right-click and choose Open Terminal here.

What sudo su did was to switch from current user to root user (superuser/admin). It means that your current user doesn't have enough privileges to do that action (Open Terminal here). You need to go to User Accounts and elevate the current user account rights (in Advanced Options, some checkbox for User monitors system changes or something like that). That's how it looks in my Xubuntu, in Unity might be some different names, but it surely is something about user rights.

-1

Try using krusader file manager. It has built in terminal emulator that opens in same directory.

Type in terminal

sudo apt-get install krusader
1
  • no i don't want to install any new file manager. I think what i am asking is also possible in nautilus file manager. Jun 9, 2016 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.