2

After having setup MaaS (DHCP configured), I am able to PXE boot a node but get a lot of warnings like "Temporary failure to resolve proxy" with Xenial after it reaches its login screen. Then it shuts down and gets enlisted in MaaS gui. I configure ipmi and then commission the node (no shutdown and ssh allowed) which causes it to boot up. Again, it has the same warnings/errors and waits on login.

After a while commissioning has failed in MaaS gui, when I click on the node it has the following summary.

Output of lldpd error file: lot of errors on failure to fetch .. Temporary failure resolving proxy.

I have set proxy in the MaaS server gui such that apt-get works correctly and I can import images. Also having IP forwarding enabled I thought I was good.

Is this upstream DNS related - i set it from the etc/resolv.conf file. Did not seem to matter.

System Details:

Ubuntu Version: 16.04 (4.4.0-22-generic) MaaS:"version": "2.0.0", "subversion": "beta6+bzr5073"

I have 2 systems. One is configured as MaaS server and has 2 nics, on gets dhcp and has external access the other on private network which maas manages. I have a second node that connects to this private network and gets dhcp from the MaaS.

The primary network interface (maas -external network) Behind Corp net

auto ens2f1
iface ens2f1 inet dhcp

MaaS Managed private network

auto ens2f2
iface ens2f2 inet static
    address 192.168.1.10
    netmask 255.255.255.0
    iptables -t nat -A POSTROUTING -o ens2f1 -j MASQUERADE
    iptables -A FORWARD -i ens2f1 -o ens2f2 -m state --state RELATED,ESTABLISHED -j ACCEPT
    iptables -A FORWARD -i ens2f2 -o ens2f1 -j ACCEPT

The new node pxe-boots and its BMC gets IP 192.168.1.191 and node itself gets 192.168.1.192.

  • I had a similar problem with 14.04 and MaaS 1.9.3, which was caused by squid proxy using IPv6, and failing on dns. I don't know if it's related to your issue, but I was able to work around by putting dns_v4_first on in squid. – user508889 Jun 7 '16 at 19:59
  • Did you set /etc/apt/apt.conf and /etc/environment for proxy configuration? – Rastin Jun 9 '16 at 20:54
  • You may want to enable ip4 forwarding and start each of the iptables lines in /etc/network/interfaces with pre-up – txwikinger Jun 9 '16 at 22:45
  • Resolved the issue, had 2 things missing: 1. IP forwarding 2. since I am behind a corp proxy, maas dns cant resolve the proxy so I had to give the actual ip of the proxy and that worked, i can now deploy nodes too. Thanks for the comments. – Harshad Sane Jun 9 '16 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.