3

I've just installed a fresh Xenial on a server box and almost immediately tried to install Docker on it.

The Docker installation page says that you have to create a /etc/apt/sources.list.d/docker.list file and add just the docker repo source in it:

deb https://apt.dockerproject.org/repo ubuntu-xenial main

then, just going through the normal apt-get update & install process. This step is usually very easy but on this brand new xenial, the update step timeouts all the time:

Failed to fetch https://apt.dockerproject.org/repo/dists/ubuntu-xenial/InRelease  Connection timed out after 120000 milliseconds

The important point here is that Docker tells me that they don't have a InRelease repo. Normally, an apt-get update should try the InRelease step, not find a signed inline source and should then try the the Release source.

My problem is that my brand new Xenial stops there without trying the Release source.

How can I force Ubuntu to check the https://apt.dockerproject.org/repo/dists/ubuntu-xenial/Release source instead of https://apt.dockerproject.org/repo/dists/ubuntu-xenial/InRelease ?

If needed, here is the uname -a result:

Linux sd-83589 4.4.0-22-generic #40-Ubuntu SMP Thu May 12 22:03:46 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I had no problem installing other packages (zsh, screen, etc..)

Please feel free to ask me any additional information: I'm way over my knowledge on this so I probably have forgotten something...

1 Answer 1

2

Thanks to Law29's comment on ServerFault I learn that some updates are made with HTTPS when others use HTTP :/

I could check with curl that HTTPS request wouldn't reach the server.

Turns out is was my firewall which was not configured to accept port 443 requests... Adding the right lines solved the problem ! Thanks Law29 !

3
  • and what is the solution? May 3, 2017 at 15:35
  • Well, if you have installed and configured a firewall on your server, as I said on my reply, you need to modify it's configuration to accept port 443 requests. The method to do it depends on your firewall so I cannot give a universal answer, sorry :/
    – gfd
    May 3, 2017 at 17:15
  • port 443 is not available on any of the links in the sources.list anyway upgraded to 17.04 and everything works fine May 4, 2017 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.