6

How do I disable Spotify notifications? Remove spotify pop-up notification when a song starts doesn't work, as there's nothing called "notification" in the ~/.config/spotify/Users/[Spotify user name]-user/prefs file

  • I tried to disable in the display options but it only show to have show unavailable songs in playlist, show announcements, and show friend feed, there's nothing about show desktop notification – user612638 Oct 28 '16 at 17:10
3

As @edwinksl said in a comment you can actually do this right from the GUI.

  1. Hit the down arrow in the top right corner
  2. Select the settings option
  3. Last option under 'Display Options' should read 'Show desktop notification....' tap/click that and they'll be disabled.
| improve this answer | |
2

Ok, simply adding ui.track_notifications_enabled=false as the first line of the file works. It's apparently normal if the field doesn't exist

| improve this answer | |
  • I have always disabled this inside the Spotify GUI client actually. Do you see the "Show desktop notifications when the song changes" option in "Settings"? – edwinksl Jun 8 '16 at 19:14
0

Quit Spotify and add ui.track_notifications_enabled=false in a new line anywhere in this file:

~/.config/spotify/Users/[spotify-user-name]-user/prefs

or ~/snap/spotify/current/.config/spotify/Users/[spotify-user-name]-user/prefs

and save.

  • If nothing has changed, make sure you have quit Spotify and try editing the file again.
  • If the prefs file doesn't exist create it and add mentioned line.

Also, you can change it in Spotify itself:

Settings > Display Options and toggle off: Show desktop notifications when the song changes

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.