I've got a problem booting. Ubuntu 16.04 on my Dell E6520 laptop boots normally when plugged in. However, when booting on battery power it shuts down entirely. Sometimes it makes it as far as the Ubuntu loading screen, but then stops and the laptop shuts off entirely.

I tried searching and found this results for a Lenovo Y560, though I'm not really knowledgeable about kernels so I'm not sure if a similar fix would be relevant for a Dell.

What can I do to boot while on battery power? Thanks.


I've also tried booting from USB and recovery mode while on battery power, both failed.

I've also noticed when I boot from AC power, then unplug the battery, sometimes the system shuts off on its own, but only after I do something.

Reproduction steps:

Shutdown at login screen issue

  1. Boot from AC power
  2. Wait for login screen
  3. At login screen, unplug AC power
  4. Type password and click login
  5. Immediately after clicking login, the laptop shuts down

I set a timer and waited 10 minutes after step 3 to see if the battery was the issue, but it only shuts down if I take an action, in this case clicking the login button.

Shutdown using Chrome on battery power

  1. Boot using AC power
  2. Wait for login screen
  3. Type password and click login (still from AC power)
  4. Wait for desktop to load, then disconnect AC power
  5. Open Chrome
  6. Type http://www.google.com in the address bar
  7. Click Go or press CTRL+Enter, and the laptop immediately shuts down

I left the laptop powered on at step 5, thinking maybe it was a battery issue. It ran for almost 3 hours until the battery was completely drained.

It seems the laptop only shuts down when on battery power after some type of user action, or during boot from battery power.

I'm stumped, any thoughts on what the cause is?

  • Does the power issue appear in Windows as well? Or only Linux? Chances are that Linux power handling isn't as efficient and your battery is old meaning it doesn't have a full charge (which could cause this)
    – Thomas Ward
    Jun 7, 2016 at 23:42
  • @ThomasW. its a rebuild - so no windows. The battery is brand new, and charges fine and runs for hours as long as I've booted with it plugged in.
    – ak_
    Jun 8, 2016 at 3:02
  • 1
    @Sneetsher actually the grub menu comes up on its own. If I choose Ubuntu it makes it to the loading screen then shuts off.
    – ak_
    Jun 10, 2016 at 4:18
  • 1
    @Sneetsher I just tried booting from USB, which also failed.
    – ak_
    Jun 10, 2016 at 4:23
  • 1
    @Sneetsher sorry for the delay, recovery mode also fails. It begins to load then shuts off.
    – ak_
    Jun 10, 2016 at 20:22

3 Answers 3


I had the same issue on a Lenovo G50-45, the fix for this was so simple it made it complicated.

Go to 'System Settings' in Ubuntu, go to 'power' and change the option below "On Battery Power" so they are the same as the options below "When plugged in".

Let me know how you get on! :)

  • Thanks, its definitely not that. The power settings are the same for both. I don't see what affect that would have on booting.
    – ak_
    Jun 10, 2016 at 4:20
  • If they are the same, then I'm not sure. I will have a look round to see if I can find anything. If I remember rightly, for myself it was set to Suspend when left for 5 minutes but only on battery power and by changing it to not suspend (The same as with power cable connected) I fixed the problem. I don't know why it was doing that, it wasn't even on the loading screen for a minute before either crashing or turning off. Jun 10, 2016 at 15:22
  • Just thought of something actually, I used to support Dell laptops in a previous role and often used to get battery calibration issues. Normally battery calibration issues just cause problems with laptops turning off without any warning. We used to support Dell D620s and D630s, so they might not have it now. They did have a calibration tool in the BIOS. Just in case you don't know, what it does is scans the chip in the battery and gets an accurate reading of battery life and resynchronizes the system. Jun 10, 2016 at 15:32
  • If there is no tool to do that in the BIOS, someone here might be able to suggest a good program for the job. As I have not had to do this on linux as of yet. Jun 10, 2016 at 15:35

I've been facing a similar problem with Ubuntu Mate 20.04 recently and after a couple of days and countless attempts to find the solution (adding dis_ucode_ldr in grub did not help) finally discovered a simple one that has worked for me.

Try editing grub adding the nomodeset option in the line GRUB_CMDLINE_LINUX_DEFAULT (if present), so that it reads as follows:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Hope that might help someone as well.

More details on nomodeset here: What does `nomodeset` do


You can add this line


into your grub file /etc/default/grub as a root user of course.

This allows booting after a bad microcode update and fixes the non-booting issue when you are not on AC Power. I've seen this issue a lot of times on some Dell computers on Ubuntu.

  • You should add what this line does and how it could help with the problem.
    – Dubu
    Sep 8, 2020 at 18:31
  • This allow booting after a bad microcode update and fix the non-booting issue when you are not on AC Power. I've see this issue a lot of time on some dell computer on Ubuntu
    – johary
    Sep 10, 2020 at 18:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .