0

Yesterday my laptop shut down because battery ran out. Next time I turned it on I couldn't enable Wi-Fi. I tried to enable it with:

rfkill unblock all

but it's still not working. Please help.

EDIT: rfkill list printed this:

0: Toshiba Bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: yes
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

ip link printed this:

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
link/ether 88:ae:1d:e8:4e:ea brd ff:ff:ff:ff:ff:ff
    3: wlp7s0b1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DORMANT group default qlen 1000
link/ether 4c:ed:de:0c:5c:55 brd ff:ff:ff:ff:ff:ff
  • 2
    Try to run sudo service network-manager restart – Pilot6 Jun 7 '16 at 15:32
  • Please edit your question and post output of rfkill list and ip link commands. – thangdc94 Jun 7 '16 at 15:46
  • @Pilot6 I tried, but nothing changed – Marcipanko Jun 7 '16 at 18:48
  • Try resetting BIOS to defaults – Jeremy31 Jun 8 '16 at 10:19
  • @Jeremy31 Didn't help – Marcipanko Jun 8 '16 at 11:48
3

Your WiFi and Bluetooth Devices are hard-blocked...

There is a network-switch/button/key on your computer/laptop which could be switched OFF - means that your network hardware is disabled (hard-blocked)...

Find it and switch it ON...

  • Once when I opened my laptop I accidentally did something so these function buttons and mouse aren't working. However, Wi-Fi worked just fine afterwards and I can also use 'FN+F8' to turn on/off Wi-Fi, but it just changes 'soft: yes/no'. Is there any way to do it from command line? – Marcipanko Jun 8 '16 at 19:39
  • I don't think that you can do it with the command line, hard blocked means disabled by hardware switch... what kind of laptop do you have? – Neni Jun 8 '16 at 20:45
  • I have Tosihba Satellite A660 – Marcipanko Jun 9 '16 at 18:00
  • Give me the output of: lspci -nn | grep 'Network controller'! If it's Broadcom then try this: sudo modprobe -v brcmsmac, while the wifi indicator light should be illuminated – Neni Jun 10 '16 at 5:42
  • It is Broadcom, didn't work though. – Marcipanko Jun 10 '16 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.