13

The issue here, is, that, bluetooth used to work. It's not working at all anymore, and I'm unsure why. When I go into system settings and try to hit enable, it simply slides the little switch back to disabled. Attempting sudo hciconfig hci0 reset as listed in bluetooth is disable on Ubuntu 14.04 returns Can't init device hci0: Connection timed out (110).

rfkill list returns:

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

lspci -nnk returns:

00:00.0 Host bridge [0600]: Intel Corporation 4th Gen Core Processor DRAM Controller [8086:0c00] (rev 06)
    Subsystem: Gigabyte Technology Co., Ltd 4th Gen Core Processor DRAM Controller [1458:5000]
    Kernel driver in use: hsw_uncore
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
    Subsystem: Gigabyte Technology Co., Ltd Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [1458:d000]
    Kernel driver in use: i915
    Kernel modules: i915
00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
    Subsystem: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:2010]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
00:14.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI [8086:8c31] (rev 05)
    Subsystem: Gigabyte Technology Co., Ltd 8 Series/C220 Series Chipset Family USB xHCI [1458:5007]
    Kernel driver in use: xhci_hcd
00:16.0 Communication controller [0780]: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 [8086:8c3a] (rev 04)
    Subsystem: Gigabyte Technology Co., Ltd 8 Series/C220 Series Chipset Family MEI Controller [1458:1c3a]
    Kernel driver in use: mei_me
    Kernel modules: mei_me
00:16.3 Serial controller [0700]: Intel Corporation 8 Series/C220 Series Chipset Family KT Controller [8086:8c3d] (rev 04)
    Subsystem: Gigabyte Technology Co., Ltd 8 Series/C220 Series Chipset Family KT Controller [1458:1c3a]
    Kernel driver in use: serial
00:19.0 Ethernet controller [0200]: Intel Corporation Ethernet Connection I217-V [8086:153b] (rev 05)
    DeviceName:  Onboard LAN
    Subsystem: Gigabyte Technology Co., Ltd Ethernet Connection I217-V [1458:e000]
    Kernel driver in use: e1000e
    Kernel modules: e1000e
00:1a.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 [8086:8c2d] (rev 05)
    Subsystem: Gigabyte Technology Co., Ltd 8 Series/C220 Series Chipset Family USB EHCI [1458:5006]
    Kernel driver in use: ehci-pci
00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller [8086:8c20] (rev 05)
    Subsystem: Gigabyte Technology Co., Ltd 8 Series/C220 Series Chipset High Definition Audio Controller [1458:a002]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 [8086:8c10] (rev d5)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
00:1c.3 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 [8086:8c16] (rev d5)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
00:1c.4 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 [8086:8c18] (rev d5)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
00:1d.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 [8086:8c26] (rev 05)
    Subsystem: Gigabyte Technology Co., Ltd 8 Series/C220 Series Chipset Family USB EHCI [1458:5006]
    Kernel driver in use: ehci-pci
00:1f.0 ISA bridge [0601]: Intel Corporation H87 Express LPC Controller [8086:8c4a] (rev 05)
    Subsystem: Gigabyte Technology Co., Ltd H87 Express LPC Controller [1458:5001]
    Kernel driver in use: lpc_ich
    Kernel modules: lpc_ich
00:1f.2 SATA controller [0106]: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] [8086:8c02] (rev 05)
    Subsystem: Gigabyte Technology Co., Ltd 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] [1458:b005]
    Kernel driver in use: ahci
    Kernel modules: ahci
00:1f.3 SMBus [0c05]: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller [8086:8c22] (rev 05)
    Subsystem: Gigabyte Technology Co., Ltd 8 Series/C220 Series Chipset Family SMBus Controller [1458:5001]
    Kernel modules: i2c_i801
02:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8161 Gigabit Ethernet [1969:1091] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd AR8161 Gigabit Ethernet [1458:e000]
    Kernel driver in use: alx
    Kernel modules: alx
03:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev 73)
    Subsystem: Intel Corporation Dual Band Wireless-AC 7260 [8086:4070]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

If there's any more information you need, please simply ask!

16
sudo rmmod btusb
sleep 1
sudo modprobe btusb

This worked for me. I found this solution here.

| improve this answer | |
  • 2
    worked in Ubuntu 19.04 / GNOME 3.32.1 – naXa Sep 18 '19 at 13:43
  • Worked in Ubuntu 18.04/ Gnome 3.28.2 – arcety Oct 27 '19 at 8:59
  • Worked in Manjaro / Gnome – Cristian Rodriguez Apr 19 at 23:16
  • Worked in Ubundu 19.10 / GNOME 3.4.1 – bruno Apr 24 at 5:48
  • this just worked for me. Bluetooth stopped working after going from 19.10 to 20.04 (I have an asus b450 motherboard with built-in bluetooth) – Dennis de Best May 4 at 10:51
12

Try this:

sudo apt-get install --reinstall bluez

Updated Answer:

  • Disable and reenable your bluetooth device with the hard switch on your computer (switch or button)
  • Go to 'System Settings' >> 'Bluetooth' and activate 'Show Bluetooth Status in the menu bar'...
  • Set 'Bluetooth ON' in the menu bar and reboot your system...
| improve this answer | |
  • 1
    Already tried this, sorry. Doesn't work. – orlando marinella Jun 7 '16 at 16:32
  • what happens (with the slider) if you type in the terminal: rfkill unblock bluetooth? What happens if you type: sudo service bluetooth start? – Neni Jun 7 '16 at 16:37
  • rfkill unblock bluetooth would only do anything if bluetooth was blocked to begin with. Hold for start. – orlando marinella Jun 7 '16 at 16:38
  • Just noticed that I have the same problem (after yesterdays update I guess)... I updated the answer above, now it works... – Neni Jun 7 '16 at 16:51
  • I, uh, can't disable the bluetooth device with the hard switch. It's actually on the board. I don't have a button to turn it off. – orlando marinella Jun 7 '16 at 17:29
0

When I first added my bluetooth speaker, it was marked as blocked by soft in the list of sudo rfkill list.

After unblocking it with sudo rfkill unblock bluetooth, I was able to add it.

But after restart I am in the exact situation described in this question:

When I go into system settings and try to hit enable, it simply slides the little switch back to disabled

The device is not listed as blocked. After removing it and adding it again, it is sometimes blocked, but not always. Unblocking it again, it works.

I haven't found a quicker solution than to remove the device from the list, add it again, unblock it if necessary ...

| improve this answer | |
0

Enabling IOMMU in my BIOS fixed this problem for me and may be helpful in your situation as well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.