3

I get this hovering bar as an artifact popping many times per hour without pressing Alt-Tab, which duration 3-15 seconds with/without interaction of mouse/touchpad/keyboard

  • booting other Ubuntus and Linuxes other than 16.04 does not lead to the same problem etc with USB boots so it is a software problem in 16.04, not hardware problem (this laptop has been 3x in Support and has regular checkups)

enter image description here

  • Artifact activates sometimes just by touches with touchpad
  • Sneetsher's one-liners do not resolve the case

    # disable Alt-tab keybinding
    dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward "'Disabled'"
    dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-prev "'Disabled'"
    dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward-all "'Disabled'"
    dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward "'Disabled'"
    # prevent it, since complete disable not possible
    dconf write /org/compiz/profiles/unity/plugins/core/active-plugins "$(dconf read /org/compiz/profiles/unity/plugins/core/active-plugins | sed "s/]/, 'staticswitcher']/")"
    
  • JonasCz's answer. His proposal is the same as Sneetsher's first set of one-liners. In other words, the compizconfig-settings-manager package does not disable the hovering bar. It only disables ALT-Tab key. I still get the artifact from the touchpad only.

  • Default settings. I have default Compiz settings. No hot-corners etc.

enter image description here

I really would like to have one liner about disabling the feature because it helps me much in many systems and future upgrades/updates.

Troubleshooting methods active

  • JonasCz. Keeping now xev on and trying to found which inputs causes the artifact.

Systems: Ubuntu 16.04
Linux kernel: 4.4 and 4.6
Linux kernel options: wl
Keyboard layout: Dvorak-US = English (Dvorak)
Hardware: Macbook Air 2013-mid (6.2)

4
  • " I have noticed that the artifact activates sometimes just by touches with touchpad " also check if you set it as one of the "hot corners" in "compiz"
    – Rinzwind
    Jun 7, 2016 at 7:32
  • @Rinzwind I have default settings in all aspects. I have no hot corners or others in my system active. Jun 7, 2016 at 11:30
  • 1
    Another idea regarding troubleshooting: try running xev in a terminal, which will tell you exactly what input events there are. Then you could narrow down what is causing this, maybe the touchpad is doing things on it's own ? Jun 13, 2016 at 9:00
  • 1
    @Masi Does it happen in the Guest session?
    – user.dz
    Jun 16, 2016 at 13:58

3 Answers 3

2

You can disable the Alt + Tab switcher in Compiz Settings manager. To do so:

  • Install the Compiz Settings manager with

    sudo apt-get install compizconfig-settings-manager
    
  • Find "CompizConfig Settings manager" in the dash, open it, find the Ubuntu Unity plugin, go to the "Switcher" tab, and disable all shortcuts and checkboxes.

This will disable the Alt + tab application switcher popup.

2
  • This solution solves the case with using ALT-Tab key but I still get the artifact. This method does not disable the function. I receive now once again those artifacts about after 5 minutes of use the compiz thing. Jun 7, 2016 at 11:27
  • @Masi, In that case, I have no idea, sorry. Jun 7, 2016 at 12:15
1

There is some thing you may try:

  1. Same as JonasCz, disable shortcuts of switcher by ccsm → Desktop section → Ubuntu Unity Plugin → Switcher tab or using commands:

    dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward "'Disabled'"
    dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-prev "'Disabled'"
    dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward-all "'Disabled'"
    dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward "'Disabled'"
    

    Still one shortcut I wasn't able to find Alt`, seem hard-coded that why they flag this as duplicate of How do I modify or disable the HUD's use of the Alt key?

  2. As there is no way to disable default unity switcher, try overriding it by another. Do in Window Management section → Enable Application Switcher or Static Application Switcher or using command:

    dconf write /org/compiz/profiles/unity/plugins/core/active-plugins "$(dconf read /org/compiz/profiles/unity/plugins/core/active-plugins | sed "s/]/, 'staticswitcher']/")"
    
3
  • Can you give one-liners for your 2nd proposal? Jun 16, 2016 at 16:23
  • @Masi, as requested.
    – user.dz
    Jun 16, 2016 at 16:34
  • 1
    I tested your second option. I still get the hovering bar artifact. It both of those are not enough. Do you know what can help next? Jun 17, 2016 at 11:32
0

In Unity tweak tool (that can be installed by sudo apt-get install unity-tweak-tool or sudo apt install unity-tweak-tool in 16.04) go to Switcher, disable everything and see if it works. If neither of the answers work, chances are your touchpad and keyboard share inputs and the touchpad has gone crazy.

EDIT: If nothing happens, boot into another OS and see if a similar switcher pops up by pressing Alt+Tab and again by using the touchpad. If this keeps happening, then it's a hardware problem.

9
  • I'm not sure whether 'dconf-editor' is in the official repositories, but have you tried if it helps? I'm not sure, I'm typing this from a phone.
    – aaaltnate
    Jun 10, 2016 at 13:24
  • I'm clueless. <kbd>Alt</kbd>+<kbd>Tab</kbd> launches an almost ubiquitous command. Does it happen elsewhere out of Ubuntu?
    – aaaltnate
    Jun 10, 2016 at 15:19
  • @aaltnate I am confused what you mean? I get the artifact also by just touching the touchpad. I disabled ALT+Tab already but I still the artifact. Jun 10, 2016 at 16:34
  • So, did you try it? On another Ubuntu live USB, on OSX or on another OS?
    – aaaltnate
    Jun 12, 2016 at 21:04
  • Of course. I still get the artifact. See the body. I do not think this is a hardware problem, this is a software problem! Jun 13, 2016 at 3:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.