0

To solve this bug on the new release of Eclipse, most people use this solution. It works fine when I run Eclipse using terminal or from the default folder (/opt/eclipse/), but when I lock Eclipse to the launcher or create a .desktop file and open the file, it returns back to its default GTK.

My .desktop file is:

[Desktop Entry]
Version=Mars
Name=Eclipse
Exec=env UBUNTU_MENUPROXY= eclipse
Terminal=false
Icon=/opt/eclipse/icon.xpm
Type=Application
Categories=IDE;Development

Note: on "Exec" I have also tried /opt/eclipse/eclipse but that has not solved my problem.

Here's a video for more description.

  • Have you already tried the "more persistent fix" in the linked answer? – wjandrea Jun 16 '16 at 4:57
0
+50

I faced the same problem before. For some reason Eclipse creates a launcher icon on ~/.local/share/applications. so i edit the default Eclipse .desktop file:

  1. gedit ~/.local/share/applications/eclipse.desktop.
  2. in the line of Exec i comment the line.
  3. and write /opt/eclipse/eclipse.enter image description here
0

Try this: Make a script and put it in the "Exec=" line of the desktop file.

#!/bin/bash
export SWT_GTK3=0
eclipse
  • Hello wjandrea , thanks for helping but i think their's no difference between running /opt/eclipse/eclipse and running link file using bash script anyway i try this solution don't solve my problem. – Mohamed Slama Jun 16 '16 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.