After installing gnome shell, without any problem, after log in the fonts are missing and it looks like crap...nothing is readable.

Don't want to make it a double post, because my issue is similar to the one from this question but for me the problems have not been solved properly. After running the commands from that post, and installing the latest AMD 11.10 driver, the Gnome shell display issues have been solved. But each time I move the mouse in the upper left corner, to bring up the applications...my entire screen flickers. Without the applications been displayed, everything looks fine.

Hardware: ATI HD4870, Intel Q6600.

  • Did you have any previous drivers installed? – Bruno Pereira Nov 11 '11 at 21:52
  • The one from System settings -> Additional drivers. I think it was the Catalyst 11.7 or 11.8, I am not sure. But anyway, it was the default one from Additional drivers – bioShark Nov 11 '11 at 22:34
  • silly question, did you remove it before installing the new one??? – Bruno Pereira Nov 11 '11 at 22:45
  • not so silly, because I haven't. I did use 11.04 on it's entire cycle, and did a few installs of newer ATI drivers, without removing the old one. I thought it overrides... – bioShark Nov 11 '11 at 22:59
  • Noooooo, you need to remove them asap ;) hope it works after this, for instructions on how to delete and install again check here. – Bruno Pereira Nov 11 '11 at 23:05

The last AMD drivers (11.10) still has problems like screen flicker but you can reduce the screen flicker active the Desktop Free of Fragmentation in the Catalysm but may cause other errors and the system feels slower, to run Gnome-shell without problems install the open source drivers. check this ATI - Ubuntu Oneiric Installation Guide, install/unistall/remove, etc... open source drivers or privative drivers

| improve this answer | |
  • Didn't work, but it was a good info about Hardware Video Decode Acceleration, hence the +1 – bioShark Nov 12 '11 at 13:52
  • 1
    I will accept this answer, even though the solution is not 100% – bioShark Nov 20 '11 at 16:17

This didn't completely fix the issue for me, but it made a significant improvement. I have a Radeon HD 5770 in my desktop connected to a 24" Acer Monitor via DVI, so YMMV.

  1. Open up the Catalyst Control Center.
  2. Expand "Display Manager" in the pages tree on the left.
  3. Select your monitor (in my case "Digital Monitor (1)"
  4. Click the "Adjustments" tab on the right part of the window
  5. Change "Image Options" to "Use graphics processor for scaling"

Varying the "Graphics processor scaling" didn't seem to make a difference, but the transition to the Activities view is considerably cleaner, if not perfect.

Hope that helps a bit until we can get a permanent, real fix!

| improve this answer | |

In my case I am using an Asus laptop with Radeon HD 6470M I enabled the Tear Free Desktop under Display options within the catalyst control center and it fixed the problem.

| improve this answer | |

i have tried all the possible tweaks to overcome this problem , actually it is not the problem with gnome 3 it is the problem but with the ati drivers by the company , so plz do not install any driver after installing gnome-shell , open drivers works very fine....even when u r having both unity and gnome-shell.

| improve this answer | |
  • without the proprietary drivers, I have other graphical performances losses. One of them is not being able to run HD movies, the frame rate is a killer. Proprietary drivers at least make my Unity 3Drun extra smooth (including the compiz cube) and HD720p and 1080p run great. And it's not a hardware issue. I got used to work in Unity and I love it. I know ATI drivers are not perfect, but for now they do the job. – bioShark Jan 17 '12 at 21:30
  • if u love unity then it's not a problem the driver issue comes with those who want to have gnome shell – gunjan parashar Jan 18 '12 at 20:01
  • I did not say it's not a problem, I've said it doesn't bother me anymore. – bioShark Jan 18 '12 at 20:09

New Catalyst driver (version 12.1 - 01.25.2012), Gnome shell now work!!! (I'm in test), chek this guide to install or update - ATI - Ubuntu Oneiric Installation Guide

| improve this answer | |
  • will give it a try tonight. Thx. – bioShark Jan 26 '12 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.