1

I have two different nVidia cards. I'm using a GTX750 as my primary cards and it's connected to a 1600x900 screen. The other card, Geforce G210 is connected to another screen, but the screen stays blank. How could I get them to work?

The cards:

lspci| grep Ge 01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX750] (rev a2) 06:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce G210] (rev a2)

It seems, that I've managed to install separate drivers for the two cards, using the addition drivers tab in settings, but the other screen is still blank. Ignore that, after a second reboot, my whole linux crashed. I had to uninstall all nVidia drivers and reinstall the ones for my GTX750. So I got nowhere.

Output from xrandr | grep conn:

DVI-I-0 disconnected (normal left inverted right x axis y axis) DVI-I-1 disconnected (normal left inverted right x axis y axis) HDMI-0 disconnected (normal left inverted right x axis y axis) HDMI-1 disconnected (normal left inverted right x axis y axis) DVI-D-0 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 443mm x 249mm

So it's not detecting the other card. Also xrandr --listproviders has only one provider:

Providers: number : 1

Provider 0: id: 0x1b9 cap: 0x1, Source Output crtcs: 4 outputs: 5 associated providers: 0 name:NVIDIA-0

  • Can someone even confirm if it's possible or not? I've searched all over the internet, but noone seems to be able to help me. – BonBon Jun 8 '16 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.