6

When ever I try to use it gives this warning:

Error in skin config file at line 19: PNG read error in /usr/share/mplayer/skins/default/skinb

followed by another warning

Config file processing error with skin 'default'
  • try reinstalling mplayer, perhaps that will solve the issue – gogeccc Jun 6 '16 at 13:12
  • done that already. – Gourab dhargupta Jun 6 '16 at 14:00
  • 1
    try running it in command line mode. it always works for me there (using my play script that hunts for what i want to play and supports playlists) – Skaperen Jul 25 '17 at 4:47
2

The solution is to convert all .png files in cd /usr/share/mplayer/skins/default to png24.

You can use imagemagick:

for FILE in *.png ; do sudo convert $FILE -define png:format=png24 $FILE ; done
  • 1
    done that and works. +1 – Robert Aug 11 '18 at 22:17
1

Follow these steps to completely reinstall mplayer along with configuration files. This should get rid of errors.

Warning : This will also remove custom configuration settings you have added (if any)!!

Completely remove mplayer

sudo apt-get remove --purge mplayer

Note that because of --purge option, your Global Configuration files in /etc/mplayer will also be removed.

Remove Local Configuration files

 rm -r ~/.mplayer/

Now install mplayer back

sudo apt-get install mplayer

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.