Something happened to my keyring, I think chrome asked for a new password to create a new keyring and erased the old one, but now the process repeats. I save a few passwords and then it resets it again.

How do I completely swipe/remove/erase the keyring, so that this problem stops?

3 Answers 3


On Ubuntu 13.10 or later:

rm ~/.local/share/keyrings -fr

Next time, when setup your keyring question appears just don't setup any.


Open ~/.gnome2/keyrings/, remove all the files there that end with .keyring.

Next time keyring shows up for any reason do not enter a password for it and verify that you want to use unsafe storage. Keyring will still save your passwords and will not ask you again for a password.

Another option is to disable keyring so the deamon does not run but then you wont have keyring saving your passwords for you common programs.


A way I liked is the old way and it worked:

Press Alt+Ctrl+T.

Then, the terminal opens up, and then in there enter:


joeri@joeri-NC10:~$ passwd
Nieuw UNIX-wachtwoord invoeren: 
Nieuw UNIX-wachtwoord herhalen: 
passwd: wachtwoord is met succes aangepast
joeri@joeri-NC10:~$ sudo emacs
[sudo] password for joeri: 
joeri@joeri-NC10:~$ ^C
  • 4
    What does this have to do with the keyring? First you change the user password, which is totally separate from the keyring, and then you open emacs (but with no particular document) as root...and you do it in a way that is highly inadvisable. This would make a little bit of sense if configuration files needed to be edited, but they don't--to reset the keyring, they need to be removed. Nov 20, 2011 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.