Ever since I installed 10.10, the network applet stays with a red exclamation point for about 10 seconds. I don't know why this is happening. Please help me, this is very annoying! I didn't have this problem when I was with 10.04. EDIT: I should maybe mention the indicator appears, but it says that there are no network available. Only after the aforementioned 10-15 seconds does it detect all the networks.

EDIT 2: This question is not answered! I have tried with another computer, and the network manager is already loaded upon login, so I know it's a bug. Please help!

EDIT 3: I have the same problem with my power indicator, actually...

EDIT 4: The problem is back once again. I have counted: it takes a full 15 seconds to load after my desktop.

EDIT 5: I have filed a bug report in Launchpad here. Can ANYONE help me?

EDIT 6: Still nobody?

  • I second this. I only have one home network, I'm not using any proprietary WiFi drivers, the WiFi router is like 12 feet away, and it still takes about 7 seconds to sync.
    – Volomike
    Oct 17 '10 at 7:02

I believe this may be an inadvertent feature of Ubuntu 10.10 by where the loading of the wireless driver is done after the GUI to decrease bootup time. If you'd prefer you can think of it as either everything takes 30 seconds to startup, or the GUI appears in 20 secs and the wireless comes 10 secs afterwards. Hope that helps!

  • That was what I feared, since bootup did seem faster. Sigh. Oh, well, guess I'll have to get used to it.
    – Lyrositor
    Oct 17 '10 at 12:50
  • Sorry I couldn't be more helpful :(
    – Nick HS
    Oct 17 '10 at 12:52
  • 1
    No, this doesn't happen on other computers or when I try Ubuntu in a virtual machine.
    – Lyrositor
    Nov 11 '10 at 22:59

Just thinking aloud here: 1. Try changing the security options in the WP. Set it to access without asking a password. See if that speeds things up. 2. If the same things worked with Lucid, then I think that the drivers are at fault.

PS: I dont know anything about the development of the drivers, I am just a n00b.

EDIT: I was looking around the conf files, and saw an option in another file, that might be of use here.

at a terminal type the following

sudo cp /etc/xdg/autostart/nm-applet.desktop /etc/xdg/autostart/nm-applet.desktop.backup

gksudo gedit /etc/xdg/autostart/nm-applet.desktop

Add a line


I hope that helps.

  • The WP? What's that?
    – Lyrositor
    Oct 24 '10 at 15:51
  • He means WPA, WPA2. Switch off for speed. Also try disable (uninstall) firewall on your Ubuntu host, this can speed up NetworkManager also.
    – Extender
    Oct 24 '10 at 16:08
  • I have no firewall, and WPA won't affect anything, since I can't even SEE the networks when I boot up. Read my question carefully.
    – Lyrositor
    Oct 24 '10 at 17:11
  • I meant changing the encryption method in the Wireless access point. Oct 25 '10 at 2:31
  • I understand, but that's what I said: there are no networks displayed on startup, so even if I removed WPA from my router, it would still not show it when I boot up. And anyway, it's not unique to the network indicator, it's also the battery.
    – Lyrositor
    Oct 25 '10 at 12:50

Avoid the issue, try another network manager eg wicd!

  • 2
    No, that won't work. As I said, it's also the battery indicator that's not working well, which means it must be rooted deeper.
    – Lyrositor
    Oct 24 '10 at 17:10

The network manager used by Ubuntu is flawed. KDE's network manager (would be Kubuntu or so) can use various backends like wicd, which is what I recommend to do: remove the network-manager (search related packages with Synaptic and remove them all) and install wicd.

This error is well known, often reported on Launchpad and constantly ignored by the Ubuntu developers. They used a specifically patched version (I think they wanted to integrate some of the Ubuntu One/Social Gwibber stuff into one Gnome Applet). Anyhow... it's not useable.

  • Okay, it's over now. I installed wicd, and it could connect. So I rebooted... only to find that boot time had increased and that wicd couldn't connect anymore! So I removed wicd, rebooted; boot time was still longer, but at least everything was ready by the time I reached my desktop, which is what I really wanted. So I don't know how wicd did it, but it seems it kinda fixed my problems, albeit with a longer boot time. Looks like Nick HS was right. But thanks everyone else!
    – Lyrositor
    Oct 26 '10 at 13:21
  • @user3485 I sincerely doubt Ubuntu uses a specifically flawed version of network-manager just out of spite. Some bug # would be really helpful.
    – Nick HS
    Oct 27 '10 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.