24

Ubuntu Software instantly crashes as I try to open it. Tried to access from terminal and gives the following error:

(ubuntu-software:5523): Gs-WARNING **: failed to open plugin /usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so: /usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so: cannot open shared object file: No such file or directory
  • 8
    Try doing sudo apt-get update && apt-get install --only-upgrade gnome-software to update it. Does that fix it ? Seems to be related to this bug. – JonasCz Jun 6 '16 at 8:08
  • @JonasCz your solution worked for a while but now it is not working anymore. Giving the same error. Any help? – Parikshit S. Jun 27 '16 at 18:53
  • I don't know what the problem could be in that case - but maybe try updating it again ? – JonasCz Jun 27 '16 at 19:36
  • Tried already ! Right now using terminal and appgrid for software installations. But will be waiting for the solution. – Parikshit S. Jun 29 '16 at 19:58
  • 1
    Embarassing this happens on an LTS. :( – skytreader Jan 20 '17 at 18:25
34

I fixed the same problem myself with

sudo apt-get upgrade gnome-software 
  • 1
    That worked for me but not immediately, reboot was required ! – Krzysiek Witkowski Dec 24 '16 at 20:43
  • Mine says up-to-date perhaps a new bug in gnome-software. Meanwhile I installed Software-Center. – SparKot Mar 7 '17 at 15:03
4

I had the same problem with gnome-software not starting at all. I found a solution that worked for me on this Launchpad bug page

Remove all files in ~/.local/share/gnome-software and then the application will start, for example

rm ~/.local/share/gnome-software/*
  • 1
    16.04LTS, this didn't work for me. – SparKot Mar 7 '17 at 15:01
  • 1
    17.04 I ran rm ~/.local/share/gnome-software/* and sudo apt-get upgrade gnome-software to fix – muglio Apr 20 '17 at 3:29
  • 1
    16.04 LTS @muglio this worked for me too – Jeremy Jan 3 '18 at 20:54

protected by Community Dec 3 '16 at 19:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.