10

Ubuntu 16.04: The settings menu used to have separate settings for external mouse and touchpad, now it only contains one set of settings for both. The settings for pointer speed actually do not change any behavior of the mouse - the mouse motion doesn't change regardless the change in the speed setting.

This is what my settings look like after mouse & touchpad settings broke: enter image description here

It looks like this might have been an issue before... mouse and touchpad settings missing ...but I am running 16.04, not 14.04. There is no touchpad-indicator program by default, and when adding the repository listed in one of the answers, it didn't help anything.

This may also be related to ELAN touchpad suddenly stopped working, worked the day before, but I do not have nearly as many problems as that person is having:

The touchpad works, it is at an okay speed, I can scroll with two-fingers, but these are all settings I set before Settings broke like this. I can no longer change the speed, disable two-finger scrolling, or anything like that. No mouse settings, except for double-click speed and primary button work.

Again, this is what it is supposed to look like (something close to it). This is what it did look like, but now it looks like the one above.

enter image description here

I know an issue like this is a known bug: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1132063, but this recently happened. That bug has been an issue for a while it seems, and my machine (originally 14.04) has been through updates and new releases, and it only recently broke after an update. As well, I have a basic "Mouse: Pointer Speed" setting in mine that isn't present in the bug report screenshots.

Any way to fix this?

Edit 1: Output of xinput:

⎡ Virtual core pointer                       id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech M570                             id=10   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ BisonCam, NB Pro                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

Edit 2: Output of xinput list-props 13:

Device 'SynPS/2 Synaptics TouchPad':
    Device Enabled (151):   1
    Coordinate Transformation Matrix (153): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Tapping Enabled (301): 0
    libinput Tapping Enabled Default (302): 0
    libinput Tapping Drag Enabled (303):    1
    libinput Tapping Drag Enabled Default (304):    1
    libinput Tapping Drag Lock Enabled (305):   0
    libinput Tapping Drag Lock Enabled Default (306):   0
    libinput Accel Speed (284): 0.000000
    libinput Accel Speed Default (285): 0.000000
    libinput Natural Scrolling Enabled (289):   0
    libinput Natural Scrolling Enabled Default (290):   0
    libinput Send Events Modes Available (268): 1, 1
    libinput Send Events Mode Enabled (269):    0, 0
    libinput Send Events Mode Enabled Default (270):    0, 0
    libinput Left Handed Enabled (291): 0
    libinput Left Handed Enabled Default (292): 0
    libinput Scroll Methods Available (293):    1, 1, 0
    libinput Scroll Method Enabled (294):   1, 0, 0
    libinput Scroll Method Enabled Default (295):   1, 0, 0
    libinput Disable While Typing Enabled (307):    1
    libinput Disable While Typing Enabled Default (308):    1
    Device Node (271):  "/dev/input/event6"
    Device Product ID (272):    2, 7
    libinput Drag Lock Buttons (300):   
    libinput Horizonal Scroll Enabled (273):    1

Edit 3: Output of xinput list-props 13 after removing xinput list-props 13:

Device 'SynPS/2 Synaptics TouchPad':
    Device Enabled (151):   1
    Coordinate Transformation Matrix (153): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (279): 1
    Device Accel Constant Deceleration (280):   2.500000
    Device Accel Adaptive Deceleration (281):   1.000000
    Device Accel Velocity Scaling (282):    12.500000
    Synaptics Edges (303):  1768, 5410, 1645, 4563
    Synaptics Finger (304): 25, 30, 0
    Synaptics Tap Time (305):   180
    Synaptics Tap Move (306):   238
    Synaptics Tap Durations (307):  180, 100, 100
    Synaptics ClickPad (308):   0
    Synaptics Middle Button Timeout (309):  75
    Synaptics Two-Finger Pressure (310):    282
    Synaptics Two-Finger Width (311):   7
    Synaptics Scrolling Distance (312): 108, 108
    Synaptics Edge Scrolling (313): 0, 0, 0
    Synaptics Two-Finger Scrolling (314):   1, 1
    Synaptics Move Speed (315): 1.000000, 1.750000, 0.036866, 0.000000
    Synaptics Off (316):    2
    Synaptics Locked Drags (317):   0
    Synaptics Locked Drags Timeout (318):   5000
    Synaptics Tap Action (319): 0, 0, 0, 0, 0, 0, 0
    Synaptics Click Action (320):   1, 1, 0
    Synaptics Circular Scrolling (321): 0
    Synaptics Circular Scrolling Distance (322):    0.100000
    Synaptics Circular Scrolling Trigger (323): 0
    Synaptics Circular Pad (324):   0
    Synaptics Palm Detection (325): 0
    Synaptics Palm Dimensions (326):    10, 200
    Synaptics Coasting Speed (327): 20.000000, 50.000000
    Synaptics Pressure Motion (328):    30, 160
    Synaptics Pressure Motion Factor (329): 1.000000, 1.000000
    Synaptics Resolution Detect (330):  1
    Synaptics Grab Event Device (331):  0
    Synaptics Gestures (332):   1
    Synaptics Capabilities (333):   1, 0, 1, 1, 1, 1, 1
    Synaptics Pad Resolution (334): 65, 44
    Synaptics Area (335):   0, 0, 0, 0
    Synaptics Noise Cancellation (336): 8, 8
    Device Product ID (268):    2, 7
    Device Node (269):  "/dev/input/event6"

Settings menu after removing xinput list-props 13: enter image description here

So now all settings are working except for the touchpad speed.

  • Please edit your question and add output of xinput terminal command. – Pilot6 Jun 6 '16 at 8:41
  • @Pilot6 Done, added the output. – Zzzach... Jun 6 '16 at 23:33
  • Please add also xinput list-props 13 – Pilot6 Jun 7 '16 at 0:47
  • @Pilot6 Done, added more output. Interesting list of settings, but not exactly sure what they represent. – Zzzach... Jun 7 '16 at 1:26
7

You have installed libinput. It is used instead of xorg-synaptics to manage the touchpad.

Unfortunately current Ubuntu with Unity DE does not have libinput settings GUI by default. unity-control-center can control only of xorg-synapics.

Another option is to uninstall xserver-xorg-input-libinput package and use xserver-xorg-input-synaptics that is installed by default instead.

  • Looks like libinput was installed automatically with an update. If I try to remove it, tons of packages come up to remove, so I cannot remove it. I installed gnome-control-center and ran it as you showed, and the mouse and touchpad options come up, but they do not actually change the values. I can even "turn off the touchpad" and it will still work. The speed sliders have no effect on the speed of the mouse. Can I make xorg-synaptics be used as the input manager instead? – Zzzach... Jun 7 '16 at 2:03
  • Are you using Ubuntu, or some other derivative? On my 16.04 xserver-xorg-input-libinput was not installed by default and does not remove any packages. Also libinput is worth keeping. It is good. You can conrol the touchpad using CLI. – Pilot6 Jun 7 '16 at 2:07
  • Ah okay so there fixes one of my problems. I removed the xserver-xorg-input-libinput package, and my settings menu and my xinput output changed (I'll update the question in a second). The mouse speed is now working (which is huge), but the touchpad speed settings still have no effect on the actual touchpad speed. I can disable the touchpad now - it's just the speed that doesn't work. – Zzzach... Jun 7 '16 at 2:18
  • You got the menu back for me, which was my original issue. Should I now open another question about the touchpad speed not working? or is it still related to this issue? – Zzzach... Jun 7 '16 at 2:24
  • Touchpad speed does not work for all touchpads. – Pilot6 Jun 7 '16 at 4:07
0

On my Lenovo Thinkpad L380 Yoga, I was having a similar issue on Pop!_OS 19.04 when I installed Unity. I had to install the xserver-xorg-input-synaptics package, and then the settings showed up.

-1

DO NOT UNINSTALL xserver-xorg-input-libinput

Especially when You are on notebook, dont have wired connection (LAN cable) and don't have any other computer.

Your keyboard and mouse will stop working. You will not be able to login to Your PC, You will not be able to launch terminal.

All You can do, is to download xserver-xorg-input-libinput and xserver-xorg-input-all on some other machine, put them on USB drive and install them manually from recovery mode.

  • download xserver-xorg-input-libinput and xserver-xorg-input-libinput two times the same? – derHugo Dec 21 '17 at 6:19
  • In this problem, however, I had another input service. If you don't have the same exact problems that I did, then don't follow the accepted solution. And repairing a broken system like that is not at all hard. Just boot into single user mode and reinstall using one of the tty's. Not even a LiveCD is needed to fix that. – Zzzach... Dec 22 '17 at 2:58
  • Corrected packages names, thanks. Also You may be concerned about this, if You are on Ubuntu (mine is 17.10) and other distros relying on libinput as default driver. – Ivan Nikolaev Dec 22 '17 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.