3

I have tried installing numerous Linux distros with no luck. In every case, it appears to be due to a failure by nouveau driver to identify my graphics card, which is an Nvidia GeForce GTX970M.

My preferred distro is either Kubuntu or Ubuntu Studio, but I have also tried ArchLinux, Fedora KDE, LinuxMint, Mageia, Netrunner, and OpenSUSE. All appear to be using nouveau driver, as they attempt to load up even the installer menu fails on most, stopping on a screen that looks like this:

enter image description here

I suspect, given what is typically shown on screen when the installation attempt stops, that the problem is with nouveau driver, so: is there a way to use the Nvidia proprietary drivers in the installation?

Or any other solution? A coworker suggested that I do a non-graphical, text-only install, but I have not found a way to do this that does not require making a menu choice first … but I can't see the installer menu.

  • You could do a minimal install from the Server ISO, and then enable the partner repository by uncommenting the line for it in /etc/apt/sources.list, then do sudo apt-get update && sudo apt-get install ubuntustudio-desktop nvidia-current && sudo apt-get autoremove --purge ubuntu-server. This would then install Ubuntu Studio packages, the NVidia driver, and remove the extra server packages which aren't needed. – dobey Jun 6 '16 at 2:46
0

I encountered a similar problem when setting up my computer with Ubuntu, which also uses the GTX970M. The solution I ended up using was to edit the boot parameters to include the nouveau.modeset=0 option.

When booting into Ubuntu, press "e" while with Ubuntu selected as the boot option to edit the boot parameters.

After quiet splash, you should add nouveau.modeset=0.

You might also try nomodeset instead of nouveau.modeset=0

This thread might also help: ubuntu 14.04 black screen when installing

  • After posting this question I tried some additional installations. One of these worked: OpenBSD. Thanks to all who responded, but I will stick with what I got to work, so I cannot comment on the proposed solutions. Thanks! – Allan Johnstone Jun 12 '16 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.