4

Short statement of the problem: short-format date shows as 6/5/16 on my desktop under the clock. I want it to say 2016-06-05. (Or maybe something else.) I'd like to find the place I tell it "Use %H-%m-%d there." This used to be doable, but I think the feature was removed somewhere along the line.

I'm running "kubuntu" 16.04, basically Ubuntu with the Plasma desktop. (It's wonderful. It's the Linux I've been looking for for years.)

I've been here. And other places. I keep finding answers that depend on gconf or dconf with particular schemas that seem to have been removed (e.g., com.canonical.indicator.datetime).

Seems that all date formats now depend on the selected locale with no opportunity for further customization. I hope someone can show me I'm wrong.

3

KDE Plasma 5 digital clock settings

From the Hour:Minute AM/PM to 24 hour clock with the ISO date.

Right click the clock widget, pick the 'Digital Clock Settings'

Appearance:

  • Use 24-hour Clock
  • Show date
  • Date format: ISO Date

enter image description here

More options to customize KDE plasma 5 clock: kde clock format: how to include the day in a non-tiny font?

  • Man. How did I miss that? I looked at that dialog, like, 100 times. THIS IS THE ANSWER. – JD Baldwin Jun 7 '16 at 16:43
  • Cool animated GIF, too. Model answer all around. – JD Baldwin Jun 7 '16 at 16:44
0

Go to System Settings on left panel --> Time and Date in System Section --> Clock

Here chose the settings you want by checking/unchecking appropriate boxes.

That's it.

  • I'm running KDE / Plasma. There is no "System" section in my settings. Only Appearance / Workspace / Personalization / Network / Hardware. Using the search function to look for "Clock" leaves only the Regional Settings, which I have already been to. Under "Formats" I can select "Detailed Settings" and drop down the box for "Time" (there is no "Date") -- which gives me only the option of "C" or some preselected country. To be fair, there are a LOT of countries in the list... I've been through just about everything in the Settings applet and I am confident the answer is not there. – JD Baldwin Jun 5 '16 at 22:14
  • sudo apt install aptitude, sudo aptitude install software-properties-gtk, sudo software-properties-gtk, the system settings window opens – rancho Jun 5 '16 at 22:26
  • I already had aptitude; I installed the software-properties-gtk package and ran it as root. That opened the software-properties-gtk dialog, not system settings. – JD Baldwin Jun 7 '16 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.