2

I'm using an HP laptop with an external screen connected through an HDMI cable, and the lid closed.

Every time I lock the screen, it dims and then cuts signal to the screen, leaving it in a blue screen that says "No Signal", and eventually it just turns off.

I want to be able to lock my screen and walk away from the computer WITHOUT having the external screen turn off.

I have gone into Settings and unchecked "Dim screen to save power" and set "Turn screen off when inactive" to "Never"

I have run xset -dpms

I have gone into dconf-editor and set com->canonical->unity-greeter->idle-timeout to 0

Nothing works.

No matter what I do, when I lock the screen (or it auto-locks), it dims and then turns off.

-1

I use xscreensaver instead of gnome-screensaver.

sudo apt-get remove gnome-screensaver

sudo apt-get install xscreensaver

Configure xscreensaver :

Lock screen

Those instructions are from here : Configure screensaver in Ubuntu

  • If your answer is essentially a referral to another question, it would be better to flag this question as a duplicate of the other once you earned 15 reputation. Don't forget to vote for the answer(s) there that you found useful! – David Foerster Nov 26 '16 at 11:22

protected by Community Nov 27 '16 at 4:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.