1

Here are my main details

  • Ubuntu 16.04 LTS

  • Acer Aspire V nitro 17

  • core i7

  • Nvidia GeForce GYX 860

Hello everyone. I've been using the "Nouveau" default graphics driver since weeks waiting for the nvidia updates relase. Yesterday (Friday June 3rd) I updated the OS and software. Doing so I saw something related to nvidia. I thought that the nvidia drivers fix/update had been released. I then chose the nvidia drivers in the software and updates > Additional driver options. After rebooting I realized that It wasn't the fix because I got the logging loop. I then did what I used to:

  • open a terminal

  • purge nvidia drivers

In order to get back to the default graphics. Then baam! Sub-process /usr/bin/dpkg returned an error (1). Saying that it encounters problems while processing nvidia-364, nvidia-364- dev and nvidia-opencl-icd-364

I read a lot of topics about it and tried a but nothing worked in my case. Any help? Thanks

closed as off-topic by David Foerster, Pilot6, andrew.46, qbi, Eric Carvalho Jun 14 '16 at 15:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – David Foerster, andrew.46, qbi
If this question can be reworded to fit the rules in the help center, please edit the question.

  • May i point you to an answer I wrote for another problem with removing nvidia drivers here: askubuntu.com/questions/783093/… – Videonauth Jun 6 '16 at 11:46
  • Can you please add a little more detail? What exactly did you do, what did you want to achieve and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. (see How do I ask a good question?) – David Foerster Jun 13 '16 at 17:56
1

Solved, unfortunately, by a complete fresh install. But I had some trouble with gnome environment and ended up giving it up. So be aware. Thank you.

  • It is frustrating. I have 16.04 installed twice on my system. One is a fresh format of the disk partition and the 361 Nvidia drivers are fine. One is my working system prior to a graphics card upgrade - and I can't figure out HOW to get it working ;) So far, all the recommended purge and file removes are not working. There is still some obscure config that isn't being covered in the more common suggestions on how fix this. Sucks to have to do a install and not determine exactly where the problem is. In my case I have no Intel graphics, pure Nvidia card (older motherboard). – RoundSparrow hilltx Jun 18 '16 at 12:01
  • 1
    Indeed!! Have you tried to report it via launchpad? In my case I haven't! Maybe they'll look at that deeply. – SAdATT Jun 18 '16 at 12:37
  • I actually made some progress. I purged more than nvidia drivers, I purged cuda and bbswitch (even though I had no Intel secondary GPU, it was altering configs). Then the most horrible thing: I had to reboot and repeat this entire sequence twice A) boot to nouveau, B) purge everything, C) use the standard Alternate Drivers to pick nvidia-361, D) boot and see if it works. What did doing it twice change? A misdetection of my HDMI / DisplayPort monitors or something? The worst kind of bug (timing?). Honestly, this is a bad part of Linux - the failsafe graphics mode doesn't work - etc. – RoundSparrow hilltx Jun 18 '16 at 12:50
  • I understand. As far as I'm concerned Nvidia might check the compatibility and furnish with relevant drivers on most OSes 😮 – SAdATT Jun 18 '16 at 12:57
0

Try this:

Switch on your computer.

Press and hold the Shift key, which will bring up the Grub menu.

Select the line which starts with Advanced options.

Select the line ending with (recovery mode)

Press Return and your machine will begin the boot process.

Your pc should display a menu with a number of options.

One of the options will be Enable networking. Press Return with this option highlighted.

Other of the options will be Drop to root shell prompt. Press Return with this option highlighted.

Your Ubuntu system boot in a terminal, run:

mount -o remount,rw /
mount --all
apt-get update
apt-get -f install
dpkg --configure -a
apt-get purge ^nvidia* ^libnvidia* 
apt-get update
apt-get dist-upgrade
apt-get install --reinstall xserver-xorg-core xserver-xorg-video-nouveau libgl1-mesa-dri-*
reboot
  • Thanks for your answer. I tried what you'd suggested. But I couldn't connect to a network. So I booted the computer in a normal way and once at logging I open a terminal with Ctrl+Alt+F1 and ran the commands. I hope it's ok. The purge command returns 3 errors :1) unable to locate package ^libnvidia* 2)Couldn't find any package by glob ' ^libnvidia*' 3)Couldn't find any package by regex ' ^libnvidia*' – SAdATT Jun 4 '16 at 23:55
  • Try with only nvidia* – kyodake Jun 5 '16 at 0:42
  • I got the sub- process error... – SAdATT Jun 5 '16 at 0:50
  • You probably need to get systemctl to start the NetworkManager before using apt to you can fetch things from the internet – Amias Jun 5 '16 at 13:04
  • Thanks. I ended up reinstalling the system by keeping my Home folder.Although I'm struggling with some app. Lile the terminal, the time and date won't display etc – SAdATT Jun 6 '16 at 12:15
0

Installing boinc-client-nvidia-cuda while in Intel mode fixed it for me (using GTX 960m).

  • Thanks. I ended up doing a fresh install. And I noticed that if I install gnome environment it'll freezes on the next booting. I assume that it might be the cause because I had gnome and unity installed at that moment. – SAdATT Jun 13 '16 at 17:39
  • Do you have gnome and unity to when having the problem? – SAdATT Jun 13 '16 at 17:39
  • I just described what I'd experienced. If it's somebody else cas maybe it's a common problem to take in consideration. – SAdATT Jun 13 '16 at 18:25
  • Updated into solved! – SAdATT Jun 13 '16 at 18:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.