2

I want to install ubuntu on a new desktop. So I followed the instruction:

  1. I downloaded an iso file (I've tried Ubuntu 14 and Ubuntu 16 already).
  2. I mounted it on a USB stick (I tried many sticks and few programs, such as iso2usb on Windows and Startup Disc Creator on Ubuntu)
  3. I set the booting sequence on my desktop computer (I'm sure it's booting from my USB stick now).

However, when I try boot the desktop computer, I still have the error:

No operating system is currently installed on this computer.

And this is true, it's a new one.

I did some research and found this question which seems to be exactly like mine. So I wanted to set the SATA mode to IDE, but there is no such option in my BIOS. I have following options: disabled (I tried setting that and it didn't help), ATA, AHCI, RAID On.

Also, I wanted to set the SATA3 mode to AHCI, but I have no such option.

The secure boot option is disabled.

What am I doing wrong? Do I need to change anything else in BIOS?

  • Are there any options in the bios to change the priority of boot devices ? If so, make sure it's set to boot from the USB stick. Another possiblility might be that you have to press a specific key during bootup - do you see something like "press F12 to select boot device" ? If that doesn't work, try a different USB stick, and a different USB port. Perhaps burning the ISO to a DVD and installing from that is an option ? What make / model is your desktop or motherboard ? – JonasCz - Reinstate Monica Jun 4 '16 at 11:52
  • @JonasCz, yes, they are. And I changed the booting sequence. I'm sure it's booting from my USB stick (or at lest, it tries to boot from it). Yes, I tried a different USB stick and a different USB port. I could install it from a DVD, but I'm hoping to be able to use my USB instead. – user2738748 Jun 4 '16 at 11:55
  • Set your boot sequence, to usb – Looserof7 Jun 4 '16 at 11:55
  • 1
    Try using Rufus, as described in the help page: ubuntu.com/download/desktop/create-a-usb-stick-on-windows - not sure what else could be the problem though. – JonasCz - Reinstate Monica Jun 4 '16 at 11:59
  • 1
    Maybe it's no longer maintained and doesn't work with newer ISOs ? Not sure though. You say you used Startup Disk creator on ubuntu, and that didn't work either, which is wiered, because it's part of ubuntu and officially maintained. No idea why that didn't work either though. – JonasCz - Reinstate Monica Jun 4 '16 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.