12

After an automatic update of the kernel on my Ubuntu 16.04 x64 I've lost any possibility to login (login loop problem). So, with Mate env I've solved a nvidia problem and installed Gnome desktop.

After a reboot, I can`t change environment from Mate to Gnome or default Ubuntu. Because whenever I click "env change icon", any buttons showed, till I press Enter. When I just enter my password without changing env, I have Mate desktop.

The question is:

  • how to repair login window? Or
  • how to set desktop env to default Ubuntu with terminal from Mate?

enter image description here

enter image description here

4
  • Did you find a solution?
    – user5950
    Sep 30 '16 at 0:34
  • I have simillar issue, anyone fixed this yet? Feb 4 '17 at 11:52
  • for the repair login window. open terminal and try ls ~ -alt and see who the owner of .XAuthority is. if it's root. chown it back to yourself and see if that fixes your problem. Mar 31 '17 at 2:19
  • I have EXACTLY same problem..
    – Ejaz
    Jan 30 '20 at 15:05
2

I had the same problem. I solved it by adding a new user, then "Log Out" and connect again. It shows then the gear icon and you can change the environment.

1

I had exactly this problem with Ubuntu 16.04. I solved it by installing a number of packages:

desktop-base
gnome-themes-standard
gnome-themes-standard-data
lightdm-gtk-greeter 
lightdm-gtk-greeter-settings
unity-greeter-badges

I also reinstalled: ubuntu-desktop and ubuntu-settings, but I don't think that was necessary. I now get a different login screen, but can choose the desktop environment from the top panel (drop down menu).

0

Selecting and Deselecting the "High Contrast Text" option in the menu that appears on clicking the top right 'gear' icon seems to solve the problem temporarily for me on Xenial. But you need to do this each time you log in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.