13

So I'll start by explaining my situation.

I actually have had my current installation for some time now (Though I upgraded from 14.04 to 16.04), and the computer I used is an inexpensive one I bought just a few years ago, and slapped Lubuntu on. However, it comes with an integrated AMD GPU, that I never installed the driver for. The consequence of this was being completely shut-off from OpenGL, which wasn't something that bothered me enough to go to the trouble of installing a driver for. Until certain software I use started making use of OpenGL.

Well, a few hours ago I decided to install the proprietary fglrx driver provided on AMD's website.

First thing I noticed was that OpenGL content now works.

Second thing I noticed was that sound doesn't. PulseAudio outright lists it as "HDMI/DisplayPort (unplugged)", even though the video still shows on my screen.

So I've been trying to make use of Google to find a solution to my issue, but nothing seems to work for me. So before I go mad, I've decided to ask the community.

Some more information:

  • I make use of PulseAudio to manage my sound, mostly because Alsa never seemed to even recognize my HDMI audio, and because my keybindings for adjusting Audio never worked for some reason. I have tried reinstalling PulseAudio, with no success.

  • Something I have already tried during my search (as some people seemed to suggest), was editing /etc/default/grub, and changing the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1". Even after rebooting, there is no change.

  • I've also tried adding my user to various groups, such as "audio", "video" and so on, as that suggestion also came up in a few searches. No change.

On person claims they simply changed the profile for their devices to "plugged", but I don't see any way for me to do that, assuming I even can.

If anyone has a solution, I'm all ears.

Edit: I ended up reverting to the "Open Source" drivers provided by Ubuntu, but for some reason, I am still having the same issue. PulseAudio still says "HDMI/DisplayPort (unplugged)" is shown, even though the HDMI video is clearly working.

3
  • Try login with the guest user or create a new temporary user and see if the problem still exists. If not, then it's a user configuration problem so try deleting the file ~/.pulse-cookie and the folder ~/.config/pulse and reboot. Jun 12, 2016 at 23:33
  • do you have another hdmi device and cable you can try this with ? it sounds like possibly your monitor doesn't have anything wired to the hdmi audio pins, this could be the case for a monitor with no sound or audio outputs.
    – Amias
    Jun 13, 2016 at 13:06
  • Today I installed an update that says: Pulseaudio: Version 1:15.0+dfsg1-1ubuntu2.2: patch d/p/0001-card-restore-setting-preferred-ports-in-entry_from_c.patch, - cherry pick an upstream commit to fix the issue of hdmi can't be restored after s3 resume (LP: #1951667). Maybe it is related to your problem
    – am70
    Dec 11, 2021 at 8:50

9 Answers 9

13

Thank you! Running this command mostly solves the problem:

pacmd set-card-profile 0 output:hdmi-stereo

If not, pressing Ctrl+Alt+F1 and then Ctrl+Alt+F7 solves it.

2
  • I often have this problem because I frequently take my laptop on the road. I have to admit I didn't try the command line, but the key sequences are faster than typing the command (I guess I could set up an alias that makes it untrue), and worked like a charm. Are there any downsides to using the terminal login trick?
    – hlongmore
    Jan 9, 2019 at 20:17
  • It's amazing and irritating: the pacmd command didn't help here but the tty-switch did.
    – Thorsten
    May 4, 2021 at 6:30
5

I have the same issue. Each time I suspend the system and wake it up, pulseaduio says HDMI is unplugged. I do the following:

  1. Press Ctrl+Alt+F1 to go to a terminal log in.

  2. Then press Ctrl+Alt+F7 to go back to the GUI.

After that, pulseaudio says HDMI is plugged in (under Output Device).

5

I had the exact same thing with an old Radeon 6900 Series.

To see info on pulseaudio devices:

pacmd list-cards

Look for the card's index and, under that, profiles. For instance, I had:

2 card(s) available.
   ****index: 0****
    name: <alsa_card.pci-0000_01_00.1>
    driver: <module-alsa-card.c>
    owner module: 6
    properties:
        alsa.card = "1"
        alsa.card_name = "HDA ATI HDMI"
...
    profiles:
        ****output:hdmi-stereo****: Digital Stereo (HDMI) Output (priority 5400, available: unknown)

Those bits of info are then used to set the output profile:

pacmd set-card-profile 0 output:hdmi-stereo

Note that the set-card-profile parameters are the card index (0) and the output (hdmi-stereo).

After that, things just worked.

Queues came from here mostly: PulseAudio reports HDMI Audio is unplugged from the Nvidia MCP79 device

3

You cant do this on the default sound properties you need pauvcontrol

sudo apt-get install pavucontrol
pavucontrol

go to the configuration Tab

find your device

choose a profile that is plugged.

updated: fixed typo in pavucontrol

1
  • ah yes , good spot fsanches , i've updated to fix
    – Amias
    Jan 4, 2017 at 14:32
1

I will try to help you. It sounds like your HDMI is working ok, but try this if you haven't already.

  1. First, plug in your HDMI cable.

  2. Go to settings and click on Displays.

    Displays

3.Now click on Mirror Displays.

  1. Finally, click on apply.

That does it for the video. Now you'll want to adjust the audio so that you hear it from you television.

  1. Click on the volume control on the top right hand corner of the monitor.

volume

  1. Now scroll down to Sound Settings. You should see this screen:Sound_Settings

  2. Click on the HDMI menu in your sound settings and you are good to go.

I hope this helps.

2
  • The OP is using Lubuntu. Sound Settings is not available. Oct 20, 2016 at 11:29
  • Mirror displays solved it for me
    – Hjulle
    Aug 9, 2019 at 11:54
1

Here is how I solved mine.

My motherboard is AMD Rs780 and my Ubuntu is 20.04.LTS, kernel 5.4.0-42

In my case, ALSA could use the HDMI sink, as I could prove by this command (it leaked sound on HDMI):

aplay -D plughw:[card],[device] /usr/share/sounds/alsa/Front_Center.wav

If you want to test as well, you can get the values for [card] and [device] with this command:

aplay -l

But Pulse still insisted that the HDMI is unplugged.

After a lot of digging, the only solution that worked for me was running the 2 following commands:

pacmd load-module module-alsa-sink device=hw:[card],[device]
pacmd set-default-sink alsa_output.hw_[card]_[device]

Here is where I found this solution: https://gist.github.com/bassmanitram/495fd35b76083f0c4a79777b8ab470fd

Unfortunately I have to run it on every logon, since I haven't find yet how to set the init file.

The link below brings more technical details of the bug, looks like there are two parameters for the HDMI card, one for the video and other for audio, and the audio parameter (eld_valid) is wrongly set to 0.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1827967

1
  • 1
    I just started having this problem on my HTPC since some Ubuntu upgrade about 4 weeks ago (I run 18.04LTS on it). The HDMI shows up as (Unplugged) randomly at boot, sometimes it's plugged, sometimes its unplugged. If its unplugged, I have to do "pulseaudio -k" to kill the daemon and usually it then works after it restarts. Really weird, it has worked for several years without any hiccups. And since it works sometimes, it can't be a configuration issue either, it must be an upgrade of some of the daemons or programs that now is unstable :/
    – BjornW
    Sep 9, 2020 at 23:21
1

I have struggled with many solution but the only solution that worked for me was set audio on with xrandr as below:

xrandr --output HDMI-1 --auto --set "audio" on

and then HDMI device changes to plugged in in pavucontrol panel.

OS: Debian bullseye

1
  • "X Error of failed request: BadName (named color or font does not exist)" Debian Bullseye, mind adding your OS specs to your answer?
    – Kevin
    May 23, 2021 at 4:10
0

You might try forcing a restart of pulseaudio, which you can do by running killall pulseaudio.

In the last month when I boot and first login, or when I recover from suspend, I see "HDMI/DisplayPort (unplugged)" or sometimes the HDMI output is not even listed; killall pulseaudio solves the problem each and every time: pulseaudio restarts itself, rescans devices, finds all the existing devices, and it works as expected, with no need of any other action.

2
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review
    – Mark Kirby
    Nov 2, 2021 at 19:59
  • for me it does. In the last month when I boot and first login, or when I recover from suspend, I see ""HDMI/DisplayPort (unplugged)" or sometimes the HDMI output is not even listed; killall pulseaudio solves the problem each and every time: pulseaudio then restarts itself, rescan devices, finds all the existing devices, and it works as expected, with no need of any other action.
    – am70
    Nov 4, 2021 at 11:13
0

The only thing that worked for me was changing the monitor scan rate from 60 to 25Hz (I am in a 50Hz country)

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.