The version that I have now on my machine is Ubuntu 11.10 Desktop dual booted with Windows XP.

The problem that I face is that I have a USB modem of Huawei Model No: EC 156. It's a Tata Photon + modem (for fellow Indian readers). When I plug that device into a USB port, it's supposed to autoplay and take me to the installer which would install the drivers and the dialer (that's what the Customer Care of Tata Photon + has told me). But, it doesn't autoplay or install anything.

But, the network manager detects the device. I tried setting it up from the network manager. The connection is set up but it doesn't connect to the network. There's no error message or anything (it just says than I am not connected to the network). I read the Ask Ubuntu threads and tried to install the following drivers:

  • usb modeswitch
  • usb modswitch data

But, those two didn't install from the Ubuntu Software Center.

  • Autoplay will work in Windows only and may be in Mac too it its supported. The manufacturers of these devices almost always seem to forget that Linux is also a widely used OS (or they really believe in Linux user's skills to get the device working themselves) – binW Jan 10 '12 at 7:59

Note:- Data cards are automatically detected in newer version of ubuntu. You just have to wait for detecting it and then you can configure it. Use this method only when your data card is not detected by default.

Plug in your modem. Let it be recognized as a flash drive. Once that is done do

1) Open terminal and type


The output will be something like this:

Bus 001 Device 001: ID 1d6b:0002
Bus 003 Device 001: ID 1d6b:0001
Bus 002 Device 002: ID 12d1:140b Huawei USB Device
Bus 002 Device 001: ID 1d6b:0001

If you have same ID 12d1:140b Hwawei USB Device> follow the same instruction below

Now the first number here is the vendor id (0x12d1) and the second one (0x0140b) is product id. These numbers will differ depending on the make and model of your modem.

2) now type in terminal

modprobe usbserial vendor=0x12d1 product=0x140b

**optional:{ only if terminal asks for permission or are you root something.. then type

sudo modprobe usbserial vendor=0x12d1 product=0x140b

enter your password ...


Now you need to install a packages and softwares below

(note: if this article is old ,download the latest packages from http://www.draisberghof.de/usb_modeswitch/ )

1) sudo apt-get install libusb-dev

For new versions of usb_modswitch, libusb-1.0 is needed. It can be installed with:

sudo apt-get install libusb-1.0.0-dev

2) Download latest usb_modeswitch & extract from:


Now to install usb_modeswitch:

cd usb-modeswitch-x.x.x( enter into the usb-modeswitch directory)

sudo make install

3) Download & extract latest usb_modeswitch-data from:


cd into the extracted folder

cd usb-modeswitch-data-xxxxxxxx

sudo gedit Makefile

add the following two lines after RULESDIR = $(DESTDIR)/lib/udev/rules.d :

UDEVDIR= $(DESTDIR)/lib/udev

UDEVDIR= $(DESTDIR)/etc/udev

now Install usb_modeswitch-data:

sudo make files-install

Once installed:

4) type again in terminal

usb_modeswitch -v 0x12d1 -p 0x140b -H -W

note:-change 0x12d1 and 0x140b if you have different vendor id and product id

5) Now try an ls /dev/ttyU* and you should be able to see at least one device, or may be more

Type in terminal

ls /dev/ttyU*

6) Now its time to configure the settings.Type in terminal


and a file would be generated(/etc/wvdial.conf)

sudo gedit /etc/wvdial.conf

Open it and modify the phone number (The default number,username and password is

number #777 username internet password internet)

but if you have changed your username and password ... then type that one.

7) now just type in terminal


thats it go to network icon and click over it and select huwaie mobile network..and you will connected in seconds..

This process 100% work if you follow the instruction carefully.

IF you have a problem ..reply

  • You do know that USB_Modeswitch is installed by default in 11.10? – Mysterio Dec 12 '11 at 18:36
  • I just thought it would be better to build binaries from latest packages source to identify his device. My device wasn't detected but after compiling from latest source ..it worked. – emtin4 Dec 12 '11 at 19:30
  • 2
    I connected to Tata Photon+ on Ubuntu 12.04 LTS. It is damn easy than windows machine. – Amit Patel May 24 '12 at 18:50
  • Today I tried same steps with ec156 and it doesn't work. Also tried my old device ec152 but it also stopped working. I am getting following error for ec152 --> WvDial: Internet dialer version 1.61 --> Initializing modem. --> Sending: ATZ ATZ OK --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 OK --> Modem initialized. --> Configuration does not specify a valid phone number. --> Configuration does not specify a valid login name. --> Configuration does not specify a valid password. Herewvdial.conf gist.github.com/AmitPatel-BoTreeConsulting/5507633 – Amit Patel May 3 '13 at 7:00
  • I removed all ; from wvdial.conf and above error gone. But now getting Modem not responding. error afterr running wvdial – Amit Patel May 3 '13 at 9:25

But, the network manager detects the device. I tried setting it up from the network manager. The connection is set up but it doesn't connect to the network. There's no error message or anything(It just says you are not connected to the network)

I've done this on 12.10, 12.04 and 11.10 and I hope it works for you as the OS is able to detect the device.

Please Try the following..

I believe this is what ur screen looks like

enter image description here

Click on the New Mobile Broadband (CDMA) Connection.. and U'll get this screen

enter image description here

Hit Continue to get this screen

enter image description here

Select Tata Indicom (Photon Plus) and Hit Continue

enter image description here

You reach this point now

enter image description here

Now ur Network Connection Dialog Box should look something like this. In the same place click on "Edit Connections"

enter image description here

Select Mobile Broadband Tab. Select Tata Indicom (Photon+) and Click on "Edit.."

enter image description here

Select Mobile Broadband Tab Again. U see a screen like this

enter image description here

Type in..

Username: internet

Password: internet

Click On Save. Then Close the window. This should get u connected.

enter image description here

  1. Check the USB Modem to see if there is any memory card already inserted

  2. Remove any onboard memory card

  3. Connect the modem and wait for network manager to detect the modem (time can range from a second to 5 minutes top)

  4. Once network manager detects the device as a modem as a mobile broadband device, click on the NETWORK indicator and choose the your device as detected and you should see network ICON rotating( indicating that the system is trying to make a connection)

  5. A CONNECTION ESTABLISHED notification will spring up if the connection is successful

  6. IF network manager fails to recognize the device as a mobile broadband device, remove the device and click on the network indicator, select EDIT CONNECTIONS

  7. A NETWORK CONNECTIONS dialog box will show up. Click on MOBILE BROADBAND and choose ADD.

  8. Choose continue and also choose the country from which you are making the connection( INDIA in your case) and select the provider from the list of providers (TATA INDICOM (Photon+) and click continue.

  9. Finally choose apply and connect the USB Modem and wait for about 5 minutes to allow network manager to recognize the device as a mobile broadband device. Once recognized, click on the device name under the network indicator to activate the connection

NB: USB modeswitch is installed by default so you shouldn't bother with those configurations

Hope this helps

*Do not forget to add username: internet and password: internet *

  • yes i didn't know about usb-mod-switch is installed by default but..when i build latest binaries from the source .. and installed it.. then according to you terminal should have prompted me with the message that ..usb-mod-switch is already the newest version... but it didn't ..so there might be two possible reason for that ... 1) i don't have this package or 2) I don't have the latest package. I have installed this in latest lm12 and lmde.. but no one prompted this message. – emtin4 Dec 12 '11 at 19:46
  • Installing from source might give u the latest version hence why you were not prompted by the Terminal about an already existing version – Mysterio Dec 13 '11 at 9:05
  • yes thats what i have written in my 2nd point.. – emtin4 Dec 13 '11 at 10:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.