15

If I try to copy 400 GB of files onto a drive that only has 390 GB of free space, will I be warned at the beginning of the operation? Or will I find out at the very end, when the space has run out?

I'm primarily interested in Nautilus, but I'd also be interested in Thunar, PCMan FM and Dolphin.

  • 6
    try it out with a pendrive ;-P – Severus Tux Jun 3 '16 at 11:55
  • 2
    Would be good if a KDE user could also add an answer here, for completeness. – Mark Kirby Jun 3 '16 at 12:37
  • 1
    @MarkKirby I just tested with a Kubuntu 15.10 Live USB, see my answer. – UniversallyUniqueID Jun 3 '16 at 14:09
13

This is my experience with Gnome 3.18, it would seem to vary based on desktop environment, i.e. Nautilus does on Gnome and Dolphin does on KDE but not the other way round, best bet is use the file manager that came with your desktop.

With Nautilus, it will warn you first, here is the exact message

enter image description here

For Dolphin, the answer was no, it tried to copy a file larger than the destination, to the destination, it did not even warn me, just stopped as if it had finished, even left the broken file in the folder.

Thunar did warn me first, here is the message

enter image description here

PCman FM did not warn me and the same as Dolphin, just left the broken file on the drive, no error messages.

| improve this answer | |
  • Hmmm.. I just tried this with Nautilus on 16.04 and it only warned me at the end.. Weird.. – Revetahw says Reinstate Monica Jun 3 '16 at 12:10
  • @Fiksdal what distribution do you have? I have Gnome, looks like tux has Unity, is yours different? – Mark Kirby Jun 3 '16 at 12:12
  • @JonasCz Not for me, it just left a broken file on my drive. Seems to be inconsistent for different users. Do you have full KDE? I ran it in Gnome. – Mark Kirby Jun 3 '16 at 12:16
  • 2
    @Fiksdal I think so, you should use pcmanfm IMO to get the early warning, seems to be based on the different desktop environments liking different managers more, likely due to integration. – Mark Kirby Jun 3 '16 at 12:18
  • 3
    Yes, Dolphin does warn me. I ran it in full KDE 5. – JonasCz - Reinstate Monica Jun 3 '16 at 12:59
9

I am using Ubuntu 16.04 LTS with unity 7.4.0 (default) . These are my results :

In Nautilus , It shows warning before copying : enter image description here

Same with Thunar,

enter image description here

But no warning in pcmanfm,

enter image description here

No warning in In dolphin, even in the end!! it just stopps when it realized that there is not enough space.

| improve this answer | |
  • 1
    Hmmm.. I just tried this with Nautilus on 16.04 and it only warned me at the end.. Weird.. – Revetahw says Reinstate Monica Jun 3 '16 at 12:09
  • Use on my answer commented Dolphin does give warning, have a look, seems to vary on diffrent DE. – Mark Kirby Jun 3 '16 at 12:19
  • @MarkKirby I am running unity 7.4 and Dolphin does not give any warning.. I am waiting for it.. – Severus Tux Jun 3 '16 at 12:37
  • Dolphin never warned me, just completed and left a broken file :( I guess we have the same results because we both use GTK based desktops. – Mark Kirby Jun 3 '16 at 12:38
  • 4
    That is pretty serious that it just stops copying without a warning even at the end! @BharadwajRaju – Revetahw says Reinstate Monica Jun 3 '16 at 19:39
3

The other answers reported no warning from Dolphin. They thought that it was because it wasn't running in full KDE.

Edit: @JonasCz gets a warning from Dolphin on KDE 5.

I just tested it out on a Kubuntu 15.10 Live USB (KDE 5).

I copied a 2 GB zero file (created by dd) to a 950 MB USB drive.

Strangely, Dolphin refused to copy the file at all. No error message. Nothing in the command line. Same when run as root.

I even tested with kioclient, KDE's backend for filesystem operations (kioclient copy /test_2gb /media/kubuntu/test_2gb). Immediately exited, no message.

Copying a small file (4 KB), which was within the space limit is fine.

The reason why Dolphin even tried to copy on other DEs is probably because it doesn't use kioclient, but something else.

Possibly related to this bug (still unfixed, reported in 2008): KDE Bugtracker issue #162211.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.