1

I have a minor problem which occurs everytime I'm installing a new application. Basically there must be some unused packages/configurations/dependencies which make some troubles. What happens is, that after the successful installation of the wanted package/application the system tries to setup/install the unwanted packages/configurations/dependencies, which will always fail.

Example:

This is what happens when I install something using

sudo apt-get install

Output in terminal:

bzad@bzad-Ideapad-S205:~$ sudo apt-get install tcc
[sudo] password for bzad: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
tcc is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up vrmcamlab (3.5.0.0) ...
sudo: unknown user: lost+found
sudo: unable to initialize policy plugin
dpkg: error processing package vrmcamlab (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of vrmagic-linux-pc-camera-runtime:
 vrmagic-linux-pc-camera-runtime depends on vrmcamlab (= 3.5.0.0); however:
  Package vrmcamlab is not configured yet.

dpkg: error processing package vrmagic-linux-pc-camera-runtime (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 vrmcamlab
 vrmagic-linux-pc-camera-runtime
E: Sub-process /usr/bin/dpkg returned an error code (1)

I've tried to use the standard clean-up terminal-lines

sudo apt-get autoremove

dpkg -l | grep ^rc | cut -d ' ' -f3 | xargs sudo apt-get purge -y

but they ended up with the same error messages. I hope this is not a duplicate somehow and I appreciate anybody who can give me a hint how I can get rid of these bodies in my ubuntu cellar.

Thanks in advance

PS: This must have happen while I tried to install the vrmagic driver packages for their stereo cameras

Behsad Ghanei

EDITS:

While going through the steps of @mchid an error occurs. Executing the following line

sh -x /var/lib/dpkg/info/vrmcamlab.postinst configure 3.5.0.0

yields

bzad@bzad-Ideapad-S205:~$ sh -x /var/lib/dpkg/info/vrmcamlab.postinst configure 3.5.0.0
+ [ configure = configure ]
+ SRC_FILE=/etc/skel/Desktop/vrmagic-camlab.desktop
+ ls /home
+ sudo -H -u bzad xdg-desktop-icon install /etc/skel/Desktop/vrmagic-camlab.desktop
+ sudo -H -u lost+found xdg-desktop-icon install /etc/skel/Desktop/vrmagic-camlab.desktop
sudo: unknown user: lost+found
sudo: unable to initialize policy plugin
  • Thankyou. It looks like you have a file /home/lost+found. Is there anything in this folder you need? If not, you should delete this folder. – mchid Jun 3 '16 at 12:06
  • You can run sudo rm -R /home/lost+found to delete the file. – mchid Jun 3 '16 at 12:07
  • 1
    That worked. I thought the folder is a recovery folder with hidden data which shouldn't be deleted. Anyway if you answer with that I will happily confirm it for yo and edit the other comments so the issue gets more clarified. Thank you – BZAD Jun 3 '16 at 12:10
  • I have updated the answer. – mchid Jun 3 '16 at 12:16
0

UPDATE

Upon further inspection, it appears you have a file that shouldn't be there. Run the following commands to fix the problem:

sudo rm -R /home/lost+found
sudo apt-get -f install

I have left the previous instructions below although, it looks like they are not needed.


previous instructions, probably not needed:

Download the "Software for USB Components" zip package from https://www.vrmagic.com/imaging/downloads/ to your ~/Downloads folder and unzip the file.

Then, run the following commands:

sudo dpkg -P vrmcamlab 
sudo dpkg -P vrmagic-linux-pc-camera-runtime
sudo apt-get install gdebi
cd ~/Downloads/VRmUsbCamDevKitForLinuxX64_4.5.0
sudo gdebi ./vrmagic-linux-pc-camera-runtime_4.5.0_amd64.deb
sudo gdebi ./vrmagic-linux-pc-camera-sdk-4.5.0_4.5.0_amd64.deb
sudo gdebi ./libvrmusbcam2_3.5.0.0_amd64.deb
sudo gdebi ./vrmcamlab_3.5.0.0_amd64.deb

You can also install:

sudo gdebi ./vrmcamserver_3.5.0.0_amd64.deb
sudo gdebi ./vrmhotplug_3.5.0.0_amd64.deb
sudo gdebi ./vrmusbcamnet_3.5.0.0_all.deb

Please post any errors.

  • Please run the following command and post the output in your answer: sh -x /var/lib/dpkg/info/vrmcamlab.postinst configure 3.5.0.0 – mchid Jun 3 '16 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.