I am a new user of Ubuntu and I use Ubuntu 16.04 LTS version. My problem is that I can not open software center. It can open before. After updating and installing some applications, can't open the software center.

  • 2
    Run in terminal sudo apt-get update. Do you get any warning for broken packages or any errors? Jun 3, 2016 at 9:13
  • Run in Terminal cat /etc/apt/sources.list and show the output. Maybe some line incorrect
    – Benny
    Jun 3, 2016 at 9:21
  • 1
    no error during update. it fine. when I click software center, it show in launcher, and disappear after a few second.
    – Nyein Chan
    Jun 3, 2016 at 9:22
  • 3
    @NyeinChan, Try running it in terminal: software-center . Then edit the question and add the error message.
    – user.dz
    Jun 21, 2016 at 3:16
  • 1
    see this --> askubuntu.com/questions/760953/…
    – RossG
    Aug 25, 2016 at 19:42

5 Answers 5


I was also facing this same problem; I followed these steps to fixed it:-

To uninstall Software Center:

sudo apt-get remove software-center
sudo apt-get autoremove software-center

To re-install Software Center:

sudo apt-get update
sudo apt-get install software-center

Thank you Mohamed Slama for askubuntu.com/a/133473/464430

  • autoremove doesn't require a package name. Default action is to scan the whole system like update does.
    – SDsolar
    Jul 1, 2017 at 8:37
  • 1
    I wonder what it's called in 16.04
    – Ron Smith
    Jul 19, 2017 at 1:19
  • 1
    I wonder what it's called in Ubuntu 20.04.2 LTS. It's not called software-center.
    – tedi
    Jun 9, 2021 at 7:05
  • Package 'software-center' is not installed, so not removed Nov 7, 2021 at 5:35
  • it's no longer software-center. it's gnome-software Feb 18, 2022 at 18:21

Similar problem happened to me after I installed 16.04.1 LTS and updated software with Software Updater in it. When I tried to install new software from *.deb file, the Ubuntu Software opened and then exited quickly. I found the answer here. Actually I just tried to

sudo apt-get update

in terminal. Then Ubuntu Software worked. I don't know why.

  • Updating to 16.04 has never worked for me. Much better is to just stick with 14.04 because it is more mature. Lots more people have posted helpful tips about it. Debugging 16.04 is much more difficult, imho.
    – SDsolar
    Jul 1, 2017 at 8:36

Rename or remove the ~/.local/share/gnome-software. In the steps below it's removed and will be recreated when you start gnome-software. It currently has a list of what has been installed.

The first line will ensure the locked up instances are removed from memory. It might not be necessary.

$ killall gnome-software
$ rm -r ~/.local/share/gnome-software

Then it should enable to open software-center from dash or with gnome-software from terminal.

Ref: here


Try to install the candidate version. It worked for me.

First, remove the snap-store. It also removes your Software Center.

snap remove snap-store

then install the candidate version

snap install snap-store --candidate

enter image description here

or, you can use another alternative, Gnome Software

sudo apt install gnome-software

enter image description here

  • Thanks a lot. the first suggestion minus the candidate version did the trick.
    – Hossein
    May 11, 2022 at 4:38

Maybe the software center is not installed. Try to install it manually:

sudo apt install software-center
  • I am also facing same problem. I have tried following commands; 1. sudo apt-get update. 2. sudo apt install software-center However the issue still persist. Software Center was working fine. It means it was installed and due some reason not working now. Dec 28, 2016 at 8:56
  • Try removing it first then update then install it.
    – SDsolar
    Jul 1, 2017 at 8:37
  • Package software-center is not available, but is referred to by another package. Nov 7, 2021 at 5:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .