0

I currently have ubuntu 12.04 and the settings -> Details does not detect the graphics card, however I get the graphics card info with:

lspci -v | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])

I want to upgrade Ubuntu but I get the following message:

Your graphics hardware may not be fully supported in Ubuntu 14.04.

Running the 'unity' desktop environment is not fully supported by your graphics hardware. You will maybe end up in a very slow environment after the upgrade. Our advice is to keep the LTS version for now. For more information see https://wiki.ubuntu.com/X/Bugs/UpdateManagerWarningForUnity3D Do you still want to continue with the upgrade?

Is it safe to upgrade anyhow, would this graphics card give me problems as it states in the message or is that message displayed because it doesn't detect the card? Any help appreciated

My system:

Memory: 31.1 Gb

Processor: Intel Core i7-3770 CPU @ 3.40Ghz x 8

OS-type: 64-bit

Graphics:

Disk: 1.9 Tb

Edit:

I tried to upgrade skipping the warning and it didn't do the upgrade do to another error "An unresolvable problem occurred while calculating the upgrade.".

So I turned off my computer and this morning when I turned it on there was a red forbiden sign on the top right corner of the desktop, I selected from the list 'check for updates' and the computer started upgrading to 14.04, however after one hour and almost at the end of the process the upgrade halted with a new error. I opened the terminal and did apt-get update, apt-get upgrade, it has been upgrading now for another hour and I see messages like "Unpacking ubuntu-docs (14.04.5) over (12.04.6) ..."

at the end: Errors were encountered while processing: /var/cache/apt/archives/autokey-common_0.90.4-1_all.deb

I tried to do sudo apt-get install mesa-utils and it did a lot of things for a while ending with this:

Errors were encountered while processing: nvidia-340-updates

nvidia-331-updates

nvidia-319-updates

nvidia-340-updates-dev

nvidia-331-updates-dev

nvidia-319-updates-dev

E: Sub-process /usr/bin/dpkg returned an error code (1)

  • The GPU is detected, according to the output above. If you want something shown in Details, install the mesa-utilspackage from the repositories. To avoid problems on old hardware, I'd recommend to switch to Xubuntu 14.04. – mikewhatever Jun 2 '16 at 15:00
  • doing this doesn't solve the problem: – user3691288 Jun 2 '16 at 15:02
  • I've seen this no-info situation on Intel graphics, but installing mesa-utils made the graphics card info start being displayed. That said, I would heed the warning that Unity won't work well, and suggest that you try Lubuntu. My netbook worked horribly on Unity 3d, and OK on unity 2d. But they dropped 2d after 12.04, I tried Lubuntu, and that's OK as well. – Organic Marble Jun 2 '16 at 15:21
1

My best answer is fire up a Live version and test it out, live is a bit slower anyway if you don't see too much of an issue then do the upgrade.

That warning though is pretty pointed, and not many people come here with that type of warning, usually we see the more, coded warnings. so this is a personal decision on your part.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.