1

Nautilus threw a SEGFAULT, the Ubuntu bug handler caught the crash and generated a crash report. So far, so good. In the bug report, it said that there some packages that were out of date. Okay, I'd like to update them. However, updating one package, , causes a bunch of other packages dependency problems.

$ sudo apt-get upgrade apt cpp-5 apt-utils dosfstools gcc-5-base init-system-helpers libapt-inst2.0 libapt-pkg5.0   libgd3 libstdc++6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 g++-5 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 gcc-5 : Depends: cpp-5 (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
         Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 lib32stdc++6 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libasan2 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libatomic1 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libcc1-0 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libcilkrts5 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libgcc-5-dev : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libgfortran3 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libgomp1 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libitm1 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 liblsan0 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libmpx0 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libquadmath0 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libstdc++-5-dev : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libtsan0 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
 libubsan0 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.3.1-14ubuntu2.1 is to be installed
E: Broken packages
$

Is there a way to resolve this issue? I looked at this post and I am not sure I like that: I assume that those dependencies are there for a reason. This one suggests some additional troubleshooting. Not sure if that is appropriate here, but better to give you information you don't need than not give you the information you do.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04 LTS
Release:    16.04
Codename:   xenial
$ 



$ grep -e '^deb\s' /etc/apt/sources.list /etc/apt/sources.list.d/*.list
/etc/apt/sources.list:deb [us.archive.ubuntu.com](http://us.archive.ubuntu.com/ubuntu/) xenial main restricted
/etc/apt/sources.list:deb [us.archive.ubuntu.com](http://us.archive.ubuntu.com/ubuntu/) xenial-updates main restricted
/etc/apt/sources.list:deb [us.archive.ubuntu.com](http://us.archive.ubuntu.com/ubuntu/) xenial universe
/etc/apt/sources.list:deb [us.archive.ubuntu.com](http://us.archive.ubuntu.com/ubuntu/) xenial-updates universe
/etc/apt/sources.list:deb [us.archive.ubuntu.com](http://us.archive.ubuntu.com/ubuntu/) xenial multiverse
/etc/apt/sources.list:deb [us.archive.ubuntu.com](http://us.archive.ubuntu.com/ubuntu/) xenial-updates multiverse
/etc/apt/sources.list:deb [us.archive.ubuntu.com](http://us.archive.ubuntu.com/ubuntu/) xenial-backports main restricted universe multiverse
/etc/apt/sources.list:deb [us.archive.ubuntu.com](http://security.ubuntu.com/ubuntu) xenial-security main restricted
/etc/apt/sources.list:deb [us.archive.ubuntu.com](http://security.ubuntu.com/ubuntu) xenial-security universe
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu) xenial-security multiverse
/etc/apt/sources.list.d/embrosyn-ubuntu-cinnamon-xenial.list:deb [us.archive.ubuntu.com](http://ppa.launchpad.net/embrosyn/cinnamon/ubuntu) xenial main
/etc/apt/sources.list.d/google-chrome.list:deb [arch=amd64] [us.archive.ubuntu.com](http://dl.google.com/linux/chrome/deb/) stable main
/etc/apt/sources.list.d/google-webdesigner.list:deb [us.archive.ubuntu.com](http://dl.google.com/linux/webdesigner/deb/) stable main
$ 

I think this issue is not important, because Nautilus mostly works, and I was not aware of the problem until the crash reporter reported the crash. Also, I'm not developing in C or C++.

Thank you for your kind assistance.

3
  • Do an sudo apt-get update followed by sudo apt-get dist-upgrade and tell me if it worked out.
    – Videonauth
    Jun 2, 2016 at 4:27
  • I think that apt-get dist-upgrade resolved the issue. Thank you. However, I don't understand why dist-upgrade worked, and just a plain old upgrade did not. At the risk of imposing on your kindness, could you please explain why? Jun 4, 2016 at 7:05
  • The difference between those two modes is merely, upgrade does an upgrade and does not care about possible conflicts, dist-upgrade does as well an upgrade but tries to resolve conflicts as far as possible.
    – Videonauth
    Jun 4, 2016 at 7:08

1 Answer 1

0

To solve this dependency issue do an sudo apt-get update followed by sudo apt-get dist-upgrade.

This should resolve your dependency issues, normal upgrade mostly isn't able to resolve issues as good as dist-upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.