0

I have also posted in github the same question. Hoping I could get some support here as well.

All the details can be found below:

https://github.com/Ubuntu-Solutions-Engineering/openstack-installer/issues/941

Briefly: Issuing this command to install openstack (Liberty) on ubuntu 14.04.4:

JUJU_BOOTSTRAP_TO=dt-01-dell-optiplex-9010sff.maas DEBUG_JUJU_BOOTSTRAP=1 sudo -E openstack-install

  • MAAS machine has internet facing eth0 and internal em1 NICs. Here is the interfaces file content:

.

# The primary network interface
auto eth0
iface eth0 inet static
        address 10.71.100.1
        netmask 255.255.0.0
        network 10.71.0.0
        broadcast 10.71.255.255
        gateway 10.71.0.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 10.10.0.1 10.71.0.1 

# The primary network interface
auto em1
iface em1 inet static
        address 10.10.0.1
        netmask 255.255.0.0
        network 10.10.0.0
        broadcast 10.10.255.255
        dns-nameservers 10.10.0.1
        dns-search maas
        post-up iptables -t nat -A POSTROUTING -o eth0 -j SNAT --to-source 10.71.100.1
        post-down iptables -t nat -D POSTROUTING -o eth0 -j SNAT --to-source 10.71.100.1
  • MAAS server and all its Nodes are connected to the same tp-link-24 port switch. No VLANs dfined.
  • eth0 is connected to the firewall and out to the internet. em1 is connected to the tp-link switch.
  • I have proper firewall rules so all of the servers (maas + nodes) going thru 10.71.0.1 can reach to the internet.
  • Cluster controller uses eth0's 10.71.100.1 IP (MAAS webGUI)
  • Region controller uses em1's (private) 10.10.0.1 IP
  • The selected machine got deployed with proper IP (10.10.200.1) although Landscape install failed.
  • Logged into it using ssh ubuntu@10.10.200.1
  • Used "nslookup maas" to see if it sees the maas machine. It did.
  • Also nslookup google.com, it could resolve it as well.
  • It couldn't nslookup couldn't resolve 10.71.0.1 from this deployed machine neither the 10.71.100.1 IP, though, I can telnet to them.
  • I put some comments below on what juju logs showed me as well.

But didn't go beyond what is pasted below (also attched). Note that I didn't get any errors. I turned on DEBUG_JUJU_BOOTSTRAP as well (you can check the logs in the github link).

My gut-feeling is that there might be some networking mishap as for some reason while juju bootstrapping, a hook (or many maybe) is failing while giving out MAAS IPs 5240 port being unreachable. I can telnet to that port and IP though from the Deployed box.

You can see my screenshots from MAAS WebGUI as well as all the logs I can collect on the github page:

https://github.com/Ubuntu-Solutions-Engineering/openstack-installer/issues/941

Any help and guidance on this would be greatly appreciated.

1

Have you tried changing your Gateway IP on your MAAS set up?

If the route to your outfacing NIC is not resolving, this could also be an IP forwarding issue. You might wanna check to see your firewall is not an issue here in case the traffic is blocked (though you can telnet to it).

  • Checked the firewall logs. No issues there. Will try the MAAS set up change for em1 interface. But I want to keep it for a while in case someone asks for more information from github. – GunerE Jun 2 '16 at 2:54
  • It doesn't seem like it. When I check the juju logs on the deployed server, MAAS server's 10.71.100.1:5240 not being found (no route) bugs me. Especially when you can install things fine on that box. you can also ping the box. – UbuntuEGGHead Jun 2 '16 at 17:27
0

I could imagine a number of things going wrong but I suspect you may have defined an apt proxy in maas and perhaps formatted it like 'ip:port' instead of 'http://ip:port'

Just a guess. That setting is in the MAAS UI, in the settings area.

  • I don't remember creating a proxy, though, I will check that out as soon as I return to the lab. – GunerE Jun 2 '16 at 17:24
  • No proxies. Only the default (the proxy input is empty). – GunerE Jun 3 '16 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.