3

Installed 16.04 fresh on a new drive yesterday. Everything worked fine, from installation to normal usage, even the touchpad with gestures and all. Today I was trying to boot a live USB with another distro (Backbox) to install alongside Xenial, but had some problems due to graphics and/or touchpad drivers missing.

After that, suddenly the touchpad stopped working in Ubuntu as well, not even a cursor. A USB mouse works. I've tried every "solution" Google can find, I think, including:

  • install/reinstall xserver-xorg-input-synaptics
  • modprobe -r psmouse && modprobe psmouse proto=imps
  • checking dconf (as in the answer here: https://askubuntu.com/a/369229/40894)
  • Fn key + F10 (toggle touchpad) -> touchpad is not even available in System Settings
  • Adding i8042.reset i8042.nomux i8042.nopnp i8042.noloop to grub boot options (https://askubuntu.com/a/528429/40894)
  • Forcing insecure boot (sudo mokutil --enable-validation) -> this made the touchpad work only as a PS/2 mouse (for a while)

Even a newly downloaded ISO (today) won't boot the installation program with touchpad recognised. Why would it work yesterday and this morning and suddenly stop working? I'm hesitant to file a bug report since I don't know yet why it just stopped working.

The system setup:

  • XMG C404 (Gigabyte P34Gv2 motherboard)
  • ELAN touchpad
  • Nvidia GTX 860M
  • Dual-booting Windows 10 (separate drive)
0

Turns out, it's a hardware problem. The same issues have shown even when booted in Windows and charger connected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.