3

I've got a Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] wlan card (found via lspci under 03:00.0 Network controller:) on my Lenovo T420 which has win7/Ubuntu 16.04 LTS dualboot. Currently WLAN doesn't work on my Ubuntu16.04 OS while WLAN works flawlessly under windows, therefore I exclude damage on the card. The specific problem is if I click on the Internet symbol (top right corner, left to the signs that display Bluetooth and which country's keyboard layout I'm using) I can't find any of the WIFIs surrounding my laptop that I can find without any problem under win7. I conclude that there must be something wrong since I remember using an Ubuntu system some years back that also found WIFI connections automatically.

I found that the little WLAN-lamp on the bottom of the laptop monitor often wasn't glowing, I concluded that the card wasn't activated.

ifconfig delivered (No Ethernet plugged in):

enp0s25   Link encap:Ethernet  HWaddr 00:21:cc:6c:57:c4  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:14951 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13581 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9938054 (9.9 MB)  TX bytes:1650168 (1.6 MB)
          Interrupt:20 Memory:f2600000-f2620000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:9376 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9376 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:1040510 (1.0 MB)  TX bytes:1040510 (1.0 MB)

I knew beforehand that the wlp3s0 interface should be up. So I checked if its in iwlconfig (no Ethernet plugged in):

enp0s25   no wireless extensions.

lo        no wireless extensions.

wlp3s0    IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

I activated it using:

sudo ifconfig wlp3s0 up

ifconfig then displayed the same as before but additionally:

wlp3s0    Link encap:Ethernet  HWaddr 08:11:96:25:81:e0  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I checked with nmcli-g:

STATE         CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN    
disconnected  none          enabled  enabled  enabled  enabled 

The card should be supported by my current kernel (found via uname -a: Linux isofruit-ThinkPad-T420 4.4.0-22-generic #40-Ubuntu SMP Thu May 12 22:03:46 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux) from all that I've found, meaning the driver should be on there.

 $ lsmod | grep iwlagn

returns nothing. Modprobe on iwlagn and dmesg give me:

$ sudo modprobe iwlagn
modprobe: FATAL: Module iwlagn not found in directory /lib/modules/4.4.0-22-generic
$ dmesg | grep -i iwl
> [    7.061277] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[    7.066591] iwlwifi 0000:03:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
[    7.103547] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    7.103551] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[    7.103553] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[    7.103556] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6205 AGN, REV=0xB0
[    7.103655] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[    7.135783] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[    7.446974] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[ 1197.242686] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1197.242927] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1197.243020] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 1197.525577] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1197.525810] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1197.525901] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 1456.897367] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1456.897637] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1456.897739] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 1457.179161] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1457.179419] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1457.179591] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 3024.765374] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3024.765672] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3024.765777] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 3025.037457] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3025.037730] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3025.037833] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 3162.486526] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3162.486837] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3162.486943] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 3162.768909] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3162.769163] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3162.769266] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0

Further sudo lshw -C network returns:

*-network               
       description: Ethernet interface
       product: 82579LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: enp0s25
       version: 04
       serial: 00:21:cc:6c:57:c4
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:25 memory:f2600000-f261ffff memory:f262b000-f262bfff ioport:5080(size=32)
  *-network
       description: Wireless interface
       product: Centrino Advanced-N 6205 [Taylor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 34
       serial: 08:11:96:25:81:e0
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-22-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:28 memory:f2500000-f2501fff

Scan for networks returned:

$ iwlist scan
enp0s25   Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlp3s0    No scan results

sudo rfkill delivered:

$sudo rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

Sadly, I couldn't find any solution for my problem since others either had a hardware problem or didn't get a solution for their problem at all. All the data above was taken while Ethernet cable was not plugged in.

Thanks in advance for all comments/replys! Cheers, Isofruit

6
  • Please include the output of sudo rfkill list in your question.
    – gertvdijk
    Jun 1, 2016 at 14:35
  • @gertvdijk : Done Jun 1, 2016 at 14:48
  • @anonymous2 Thanks for improving the formatting! Jun 1, 2016 at 14:57
  • No problem - that's what reviewers are there for... :)
    – anonymous2
    Jun 1, 2016 at 15:18
  • Say, have you tried manually entering the SSID for your router and setting up the network that way? I've occasionally had no networks detected, but have still been able to set up that way - especially with Lubuntu and Xubuntu.
    – anonymous2
    Jun 1, 2016 at 15:20

0

You must log in to answer this question.

Browse other questions tagged .