0

I cannot boot from a USB drive. The installer boot menu comes up with a countdown, but pressing anything freezes it. If I don't do anything it counts down to 1 and freezes.

I have checked the md5 sum, and I am booting from my USB port. I have tried creating the bootable USB with unetbootin and pendrivelinux.

It seems to be a fairly common problem, yet I can't find any solutions,

  • What computer do you have? – kek Jun 1 '16 at 14:27
0

The screen freezes for a while, but then it proceeded to the setup screen. Try waiting a minute or so for it to work. The other day when I installed Ubuntu 16.04 on a new laptop, I pressed enter on the installer boot menu. It froze for a minute but then it continued to the installation process. This is not the first time I have seen this happen. My guess is that when it freezes, it is trying to load the file for the setup.

0

I have a few possible solutions for you, in order of complexity:

  1. Try disabling Secure Boot. As discussed here: Installing Ubuntu Alongside a Pre-Installed Windows with UEFI, Secure Boot is supposed to work, but it doesn't always.

  2. Try using a different USB or booting from a DVD. USB drives fail all the time, sometimes not catastrophically, but enough that booting isn't possible.

  3. If you have another computer which can boot off of this USB drive, you could disable or remove the harddrives from that computer, put the harddrive you want to install Ubuntu on into this computer, and install that way.

  4. If you have some other way to boot the computer you are working with, I have had good luck setting up a virtual machine with physical harddrive access (Be careful to not give it any mounted partitions! Keep backups!) and installing through the VM, even installing the bootloader!

  5. Depending on how much effort you're willing to spend on this, and how advanced you are at using Ubuntu, you could try installing via PXE boot. This requires, that I can think of,

    • Another computer to use as the PXE server
    • A DHCP server which supports passing the PXE server information
    • The computer to install on must support network booting

A full guide is here: https://help.ubuntu.com/community/PXEInstallServer. The details will vary depending on exactly how you set it up. Basically:

  • Install needed packages: sudo apt-get install inetutils-inetd tftpd-hpa
  • Edit /etc/default/tftpd-hpa to have:

    RUN_DAEMON="yes" OPTIONS="-l -s /var/lib/tftpboot"

  • If you are using dhcpd for a DHCP server, add:

    filename "pxelinux.0"; next-server <pxe host>;

    to your subnet declaration, replacing with the ip address of the PXE server

  • Finally mount the iso: mount -o loop ubuntu.iso /var/lib/tftpboot

Connect the computer you want to install on to your network with an ethernet connection and select network boot. You should eventually be presented with a text-based ubuntu installer!

I hope that the network install steps I have included are complete. I haven't set it up in a while.

  • In addition to Sompom's very good answer i should say you need to make sure that your bootable USB has the same partition table style as your internal disk (MBR or GPT). In Windows, go to Start menu and look for a program called "Create and format hard disk partitions". Open it, select Disk 0 tile and right-click on it. Choose Properties and go to Volumes tab. Look at Partition Style: GUID Partition Table (GPT) or Master Boot Record (MBR). Then use Rufus (under Windows) to create a new partition table (same type as hard disk) and write the iso file again to usb drive. – ipse lute Jun 1 '16 at 15:15
  • Thanks for help guys, tried using a different brand of USB stick and success. Not sure why, just happy its working. – Iain Jun 1 '16 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.