0

since this problem seems to be recurring throughout distros and versions, I looked it up in most boards and of course [...] <- spare rambling about Google skills here. This did not solve it so far. Therefore:

System:

Lenovo X200, Xubuntu 16.04 with no extras or tweaks installed, lightdm,
Eizo FlexScan S2401W external display over VGA, attached to Ultrabase

On the same system I ran Xubuntu 14.04 before and everything worked perfectly.

Problem:

Working system, using Ultrabase & ext. display but:

  • Suspending system (method does not produce different outcome as implied in other threads, i.e. it does not make a difference whether I use some menu or button or the wall to suspend my notebook - ok wall does probably)
  • On Login screen cursor is visible but screen does not appear in native resolution
  • After login pointer is missing, mouse is working though (since I can see my movements, only the cursor icon is gone)

Temporary "solution":

I have tried sudo modprobe -r psmouse just to see if it changes anything, but does not. This problem does seem to be a graphics issue to me. It disappears after switching between monitors in the Display applet 2 times.

Display applet/dialog screenshot

When I select Laptop only (s. left, image), I immediately see the cursor on my laptop screen. Switching back to only Eizo Nano[...] (s. right, image) obviously refreshes the output for this device and the cursor reappears.

During the whole thing, the native resolution of my display (Eizo) is maintained. There is no issue with that after login anymore. However, the resolution does not seem to be recognized immediately by the system on startup or on wakeup, since the login screen is always stretched on the monitor.


Question:

What can cause this issue? (which application/driver?)


I am not looking for:

a different display manager / desktop environment / some bloated tool

I'm looking forward to any (terminal) input, weird ideas or experiments!

Thanks in advance,

Mauzi

  • Maybe this or this ? Not sure it helps. – Videonauth Jun 1 '16 at 8:05
  • @Videonauth: Thanks, but those do not match my problems. I have no problem with pointer accuracy or screen resolution once logged in. I suspect issues with X or similar but I am not well-informed enough to make a good guess. I have no flickering issues with the cursor. But what is reproducible is that if I log off and choose another session (gnome session) from the menu in the log-on screen, then I can login again to the xsession and the cursor works again. If I don't try to start a gnome session inbetween, the cursor will still be missing, both in "xubuntu session" and "xfce session". – Mauzi McMau Jun 1 '16 at 12:25
1

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1568604

Check out Post #143 in that thread.

Argh, missed a “”→"" (I stupidly copy-pasted my script from another place I'd posted it instead of from the actual file …). Trying again:

sudo mkdir -p /usr/local/bin

echo '#!/bin/sh 
        n="$(fgconsole)" || exit 1 
        case "$n" in 
            [0-9]) /bin/chvt 1; /bin/chvt "$n";sleep 1;;
                *) echo "error from $0; fgconsole gave $n" >/tmp/VTswitch.log 
        esac ' | sudo tee /usr/local/bin/VTswitch

sudo chmod +x /usr/local/bin/VTswitch

sudo mkdir -p /etc/lightdm/lightdm.conf.d

echo '[Seat:*] 
        session-cleanup-script=/usr/local/bin/VTswitch 
      ' | sudo tee /etc/lightdm/lightdm.conf.d/50-vtswitch.conf
sudo systemctl restart lightdm

I'm running Ubuntu Studio 16.04 (XFCE) on an Asus laptop, after being on 14.04 until just this June.

The 'Lock Screen' function (or 'Suspend w/ Screen Lock') would cause my mouse cursor to be invisible upon waking/unlocking.

Running the instructions in post #143 quoted above logged me out and as soon as I logged backed in and locked/unlocked the screen- I could no longer reproduce the bug.

I am examining the details of the commands to better understand them, I think it's just a work around, not a true fix though...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.