11

I've been trying to install Mendeley on ubuntu 16.04. I followed the installation guide on their website but it simply doesn't start. The icon appears when I run it and in 3 seconds it disappears. Any thoughts?

Output of running mendeleydesktop in terminal

Unable to use Qt libraries in /usr/lib/x86_64-linux-gnu. Some components are missing:
 /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4 To run Mendeley Desktop you may need to install the QtWebKit and QtSvg packages provided by your Linux distribution. Using bundled SSL runtime libraries /usr/bin/../../opt/mendeleydesktop/bin/mendeleydesktop: error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory 
  • Could you please add the project URL and the package-name to your original post (by editing it). i can't find any package called mendeley in the 16.04 repository. I assume you are talking about mendeley.com – dufte Jun 1 '16 at 7:28
  • If an application seems to crash it often helps to start it from a terminal/commandline. The advantage might be that it outputs some error code or similar which might be a good starting point on the search for a solution. – dufte Jun 1 '16 at 7:31
  • 1
    It starts here properly on 16.04 and displays a login dialog with register and signin option. – dufte Jun 1 '16 at 7:33
  • 1
    Works for me too on gnome-1604, open a terminal and run mendeleydesktop and add any and all output to the question. – Mark Kirby Jun 1 '16 at 8:05
  • 2
    Instructions at mendeley.com/download-mendeley-desktop/ubuntu/instructions work for me on Ubuntu 16.04. – edwinksl Jun 1 '16 at 8:36
12

Open a terminal and run

sudo apt-get install libqtsvg4-perl libqtwebkit4

I had this exact error and after Mark Kirby's answer I still had the problem. After running the above, now Mendeley launches and syncs all my data (yeah!).

What I don't know is if it was just what I wrote above or if you need this and also Mark Kirby's answer both.

Source of answer: http://ubuntuforum-br.org/index.php?topic=120046.0

  • I was able to get it working using only your command without using the one from Mark Kirby's answer. – adamconkey Jun 29 '16 at 4:04
  • @aconkey Thanks for posting this. I'm sure it will help someone in the future. – John Jun 29 '16 at 4:21
4

You seem to be missing some dependencies qtwebkit and qtsvg

Open a terminal and run

sudo apt install qt4-dev-tools

Now try to run it again.

  • got this: 'libqt5webkit5 is already the newest version' – manutsa Jun 1 '16 at 19:47
  • Try this updated version. – Mark Kirby Jun 1 '16 at 19:55
  • I have the exact same error as the OP. This did not fix it. It did install the tools but the error I get is still the same (as in the question). Any other ideas? – John Jun 2 '16 at 12:02
  • I took this from stack overflow in case this did not work, run sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev @John Same error but different app stackoverflow.com/questions/26869830/… – Mark Kirby Jun 2 '16 at 12:04
  • Thanks @MarkKirby. After applying my answer it's working. I'm not sure if your extra solution would have also done the trick (also like the OP, I'm quite the newbie). – John Jun 2 '16 at 12:11
1

To install the minimum requirements on Ubuntu 16.04 follow:

sudo apt-get install libqtwebkit4 libqt4-svg
0

I can't comment on the answer because I don't have enough reputation points. I just wanted to say that the answer didn't work for me but installing gdebi

sudo apt install gdebi

from 16.04 Cannot install anything from Ubuntu Software center and installing through gdebi by right clicking the .deb file and opening with gdebi worked fine.

Also if you mess up the install (like I did) you can re-install using gdebi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.